CVE-2015-1814 Jenkins allows for Privilege Escalation by Remote Authenticated Users

High 7.5 Published Updated

Remote attackers can gain privileges by forcing an API token change for anonymous users in the Jenkins API token-issuing service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-1814?

CVE-2015-1814 is a high-severity vulnerability in Jenkins Jenkins, published on 16 Oct 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The API token-issuing service in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to gain privileges via a "forced API token change" involving anonymous users.

Weakness: CWE-264

Which versions are affected by CVE-2015-1814?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.596.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.596.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.5971.606
org.jenkins-ci.main:jenkins-core MavenFrom 1.5971.606

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2015-1814?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.596.2 or 1.606.

Is CVE-2015-1814 being exploited?

There is no known exploitation of CVE-2015-1814 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-3269-jqp5-v8c9.

Is CVE-2015-1814 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free