{"answers":{"affected":"4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-1814 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.596.2 or 1.606.","what":"CVE-2015-1814 is a high-severity vulnerability in Jenkins Jenkins, published on 16 Oct 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-1814 and fix it if it is affected.\n\nWhat it is: CVE-2015-1814 is a high-severity vulnerability in Jenkins Jenkins, published on 16 Oct 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-1814 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.596.2\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.596.2\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.597; fixed in 1.606\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.597; fixed in 1.606\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1814/ (Markdown: https://insights.sbomify.com/CVE-2015-1814/index.md)","id":"CVE-2015-1814","markdown":"https://insights.sbomify.com/CVE-2015-1814/index.md","name":"CVE-2015-1814","record":{"aliases":["GHSA-3269-jqp5-v8c9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CI server","requires_auth":"none","summary":"Remote attackers can gain privileges by forcing an API token change for anonymous users in the Jenkins API token-issuing service.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jenkins","vendor":"jenkins"},{"product":"openshift","vendor":"redhat"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"The API token-issuing service in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to gain privileges via a \"forced API token change\" involving anonymous users.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins allows for Privilege Escalation by Remote Authenticated Users","id":"CVE-2015-1814","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"jenkins:jenkins","products":["jenkins:jenkins","redhat:openshift"],"type":"privilege_escalation","year":"2015"},"n_packages":4,"n_references":4,"next":{"headline":"Command injection in n/a","id":"CVE-2015-1815"},"packages":[{"ecosystem":"Maven","fixed":["1.596.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-3269-jqp5-v8c9"},{"ecosystem":"Maven","fixed":["1.596.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-3269-jqp5-v8c9"},{"ecosystem":"Maven","fixed":["1.606"],"introduced":["1.597"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-3269-jqp5-v8c9"},{"ecosystem":"Maven","fixed":["1.606"],"introduced":["1.597"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-3269-jqp5-v8c9"}],"prev":{"headline":"Jenkins allows Cross-Site Scripting (XSS)","id":"CVE-2015-1813"},"products":["n/a"],"published":"2015-10-16","related":[{"cvss_score":9.8,"headline":"Jenkins Command Line Interface (CLI) Path Traversal","id":"CVE-2024-23897","kev_date_added":"2024-08-19","published":"2024-01-24"},{"cvss_score":9.8,"headline":"Jenkins Stapler Web Framework Deserialization of Untrusted Data","id":"CVE-2018-1000861","kev_date_added":"2022-02-10","published":"2018-12-10"},{"cvss_score":9.8,"headline":"Jenkins Remote Code Execution","id":"CVE-2017-1000353","kev_date_added":"2025-10-02","published":"2018-01-29"},{"cvss_score":7.5,"headline":"Jenkins User Interface (UI) Information Disclosure","id":"CVE-2015-5317","kev_date_added":"2023-05-12","published":"2015-11-25"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21690","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21691","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21692","kev_date_added":null,"published":"2021-11-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can gain privileges by forcing an API token change for anonymous users in the Jenkins API token-issuing service.","url":"https://insights.sbomify.com/CVE-2015-1814/"}