CVE-2015-1820 rest-client Gem Vulnerable to Session Fixation
Critical 9.8
Published
Updated
Check this codebase for CVE-2015-1820 and fix it if it is affected.
What it is: CVE-2015-1820 is a critical vulnerability in n/a, published on 9 Aug 2017.
Exploitation: There is no known exploitation of CVE-2015-1820 in the wild and no public exploit code.
Affected packages and fixed versions:
- rest-client (RubyGems): affected from 1.6.1.a; fixed in 1.8.0
- rest-client (RubyGems): affected from 1.6.1.a; fixed in 1.8.0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2015-1820/ (Markdown: https://insights.sbomify.com/CVE-2015-1820/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2015-1820?
CVE-2015-1820 is a critical vulnerability in n/a, published on 9 Aug 2017.
Official description
REST client for Ruby (aka rest-client) before 1.8.0 allows remote attackers to conduct session fixation attacks or obtain sensitive cookie information by leveraging passage of cookies set in a response to a redirect.
Weakness: CWE-384
Which versions are affected by CVE-2015-1820?
2 open source packages ship an affected version, including rest-client. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
rest-client RubyGems | From 1.6.1.a | 1.8.0 |
rest-client RubyGems | From 1.6.1.a | 1.8.0 |
Products include Rest-Client Project Rest-Client.
How do I fix CVE-2015-1820?
Upgrade rest-client to 1.8.0 or later.
Is CVE-2015-1820 being exploited?
There is no known exploitation of CVE-2015-1820 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2015-1820, GHSA-3fhf-6939-qg8p.