{"answers":{"affected":"4 open source packages ship an affected version, including http. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-1828 in the wild and no public exploit code.","fix":"Upgrade http to a fixed version for your release line: 0.6.4 or 0.7.3.","what":"CVE-2015-1828 is a medium-severity vulnerability in n/a, published on 6 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-1828 and fix it if it is affected.\n\nWhat it is: CVE-2015-1828 is a medium-severity vulnerability in n/a, published on 6 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-1828 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- http (RubyGems): affected all versions; fixed in 0.6.4\n- http (RubyGems): affected all versions; fixed in 0.6.4\n- http (RubyGems): affected from 0.7.0; fixed in 0.7.3\n- http (RubyGems): affected from 0.7.0; fixed in 0.7.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1828/ (Markdown: https://insights.sbomify.com/CVE-2015-1828/index.md)","id":"CVE-2015-1828","markdown":"https://insights.sbomify.com/CVE-2015-1828/index.md","name":"CVE-2015-1828","record":{"aliases":["DEBIAN-CVE-2015-1828","GHSA-6wpv-cj6x-v3jw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby HTTP library","requires_auth":"none","summary":"Attackers can intercept sensitive data via man-in-the-middle attacks because the Ruby http gem fails to verify SSL hostnames.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"http.rb","vendor":"http.rb_project"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"http vulnerable to Exposure of Sensitive Information to an Unauthorized Actor","id":"CVE-2015-1828","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2015"},"n_packages":4,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-1829"},"packages":[{"ecosystem":"RubyGems","fixed":["0.6.4"],"introduced":["0"],"last_affected":[],"package":"http","purl":null,"source":"GHSA-6wpv-cj6x-v3jw"},{"ecosystem":"RubyGems","fixed":["0.6.4"],"introduced":["0"],"last_affected":[],"package":"http","purl":"pkg:gem/http","source":"GHSA-6wpv-cj6x-v3jw"},{"ecosystem":"RubyGems","fixed":["0.7.3"],"introduced":["0.7.0"],"last_affected":[],"package":"http","purl":null,"source":"GHSA-6wpv-cj6x-v3jw"},{"ecosystem":"RubyGems","fixed":["0.7.3"],"introduced":["0.7.0"],"last_affected":[],"package":"http","purl":"pkg:gem/http","source":"GHSA-6wpv-cj6x-v3jw"}],"prev":{"headline":"The get_user_grouplist function in the extdom plug-in in FreeIPA before 4.1.4 does not properly reallocate memory when processing user accou","id":"CVE-2015-1827"},"products":["n/a"],"published":"2017-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can intercept sensitive data via man-in-the-middle attacks because the Ruby http gem fails to verify SSL hostnames.","url":"https://insights.sbomify.com/CVE-2015-1828/"}