# CVE-2015-1828: http vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

> Attackers can intercept sensitive data via man-in-the-middle attacks because the Ruby http gem fails to verify SSL hostnames.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-1828, GHSA-6wpv-cj6x-v3jw

## What is CVE-2015-1828?

CVE-2015-1828 is a medium-severity vulnerability in n/a, published on 6 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-1828?

4 open source packages ship an affected version, including http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `http` | RubyGems | All versions | 0.6.4 |
| `http` | RubyGems | All versions | 0.6.4 |
| `http` | RubyGems | From 0.7.0 | 0.7.3 |
| `http` | RubyGems | From 0.7.0 | 0.7.3 |

Products: Http.rb Project Http.rb.

## How do I fix CVE-2015-1828?

Upgrade http to a fixed version for your release line: 0.6.4 or 0.7.3.

## Is CVE-2015-1828 being exploited?

There is no known exploitation of CVE-2015-1828 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1828 and fix it if it is affected.

What it is: CVE-2015-1828 is a medium-severity vulnerability in n/a, published on 6 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-1828 in the wild and no public exploit code.

Affected packages and fixed versions:
- http (RubyGems): affected all versions; fixed in 0.6.4
- http (RubyGems): affected all versions; fixed in 0.6.4
- http (RubyGems): affected from 0.7.0; fixed in 0.7.3
- http (RubyGems): affected from 0.7.0; fixed in 0.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1828/ (Markdown: https://insights.sbomify.com/CVE-2015-1828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1828
- OSV: https://osv.dev/vulnerability/CVE-2015-1828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1828/
Summaries are generated and may contain mistakes; the official description above is the record.
