{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-1830 exists.","fix":"Upgrade org.apache.activemq:activemq-client to 5.11.2 or later.","what":"CVE-2015-1830 is a medium-severity path traversal vulnerability in Apache Activemq, published on 19 Aug 2015. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-1830 and fix it if it is affected.\n\nWhat it is: CVE-2015-1830 is a medium-severity path traversal vulnerability in Apache Activemq, published on 19 Aug 2015. It can be exploited over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-1830 exists.\n\nAffected packages and fixed versions:\n- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.11.2\n- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.11.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1830/ (Markdown: https://insights.sbomify.com/CVE-2015-1830/index.md)","id":"CVE-2015-1830","markdown":"https://insights.sbomify.com/CVE-2015-1830/index.md","name":"CVE-2015-1830","record":{"aliases":["GHSA-3v63-f83x-37x4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ","requires_auth":"unknown","summary":"Remote attackers can exploit a directory traversal flaw in Apache ActiveMQ to upload JSP files, potentially leading to arbitrary code execution.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"activemq","vendor":"apache"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory traversal vulnerability in the fileserver upload/download functionality for blob messages in Apache ActiveMQ 5.x before 5.11.2 for Windows allows remote attackers to create JSP files in arbitrary directories via unspecified vectors.","ecosystems":["Maven"],"exploits":{"exploitdb":2,"first_seen":"2015-08-17","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2015-08-17","kind":"exploitdb","ref":"40857","stars":null,"title":"Apache ActiveMQ 5.11.1/5.13.2 - Directory Traversal / Command Execution"},{"date":"2015-08-19","kind":"metasploit","ref":"exploit/windows/http/apache_activemq_traversal_upload","stars":null,"title":"Apache ActiveMQ 5.x-5.11.1 Directory Traversal Shell Upload"},{"date":"2020-03-09","kind":"exploitdb","ref":"48181","stars":null,"title":"Apache ActiveMQ 5.x-5.11.1 - Directory Traversal Shell Upload (Metasploit)"}],"tier":"weaponised"},"has_fix":true,"headline":"Improper Limitation of a Pathname to a Restricted Directory in Apache ActiveMQ","id":"CVE-2015-1830","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:activemq","products":["apache:activemq"],"type":"path_traversal","year":"2015"},"n_packages":2,"n_references":7,"next":{"headline":"Incomplete exclude pattern in Apache Struts","id":"CVE-2015-1831"},"packages":[{"ecosystem":"Maven","fixed":["5.11.2"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":null,"source":"GHSA-3v63-f83x-37x4"},{"ecosystem":"Maven","fixed":["5.11.2"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","source":"GHSA-3v63-f83x-37x4"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2015-1829"},"products":["n/a"],"published":"2015-08-19","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":9.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","kev_date_added":"2022-02-10","published":"2016-06-01"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"},{"cvss_score":9.8,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can exploit a directory traversal flaw in Apache ActiveMQ to upload JSP files, potentially leading to arbitrary code execution.","url":"https://insights.sbomify.com/CVE-2015-1830/"}