# CVE-2015-1830: Improper Limitation of a Pathname to a Restricted Directory in Apache ActiveMQ

> Remote attackers can exploit a directory traversal flaw in Apache ActiveMQ to upload JSP files, potentially leading to arbitrary code execution.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-3v63-f83x-37x4

## What is CVE-2015-1830?

CVE-2015-1830 is a medium-severity path traversal vulnerability in Apache Activemq, published on 19 Aug 2015. It can be exploited over the network, with no action from the victim.

### Official description

Directory traversal vulnerability in the fileserver upload/download functionality for blob messages in Apache ActiveMQ 5.x before 5.11.2 for Windows allows remote attackers to create JSP files in arbitrary directories via unspecified vectors.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2015-1830?

2 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.11.2 |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.11.2 |

Products: Apache Activemq.

## How do I fix CVE-2015-1830?

Upgrade org.apache.activemq:activemq-client to 5.11.2 or later.

## Is CVE-2015-1830 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-1830 exists.

Public exploit code:

- Apache ActiveMQ 5.11.1/5.13.2 - Directory Traversal / Command Execution (exploitdb)
- Apache ActiveMQ 5.x-5.11.1 Directory Traversal Shell Upload (metasploit)
- Apache ActiveMQ 5.x-5.11.1 - Directory Traversal Shell Upload (Metasploit) (exploitdb)

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1830 and fix it if it is affected.

What it is: CVE-2015-1830 is a medium-severity path traversal vulnerability in Apache Activemq, published on 19 Aug 2015. It can be exploited over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-1830 exists.

Affected packages and fixed versions:
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.11.2
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1830/ (Markdown: https://insights.sbomify.com/CVE-2015-1830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1830
- OSV: https://osv.dev/vulnerability/CVE-2015-1830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1830/
Summaries are generated and may contain mistakes; the official description above is the record.
