CVE-2015-1831 Incomplete exclude pattern in Apache Struts
High 7.5
Published
Updated
Check this codebase for CVE-2015-1831 and fix it if it is affected.
What it is: CVE-2015-1831 is a high-severity vulnerability in Apache Struts, published on 16 Jul 2015.
Exploitation: There is no known exploitation of CVE-2015-1831 in the wild and no public exploit code.
Affected packages and fixed versions:
- org.apache.struts.xwork:xwork-core (Maven): affected from 2.0.0; fixed in 2.3.20.1
- org.apache.struts.xwork:xwork-core (Maven): affected from 2.0.0; fixed in 2.3.20.1
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.20.1
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.20.1
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2015-1831/ (Markdown: https://insights.sbomify.com/CVE-2015-1831/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2015-1831?
CVE-2015-1831 is a high-severity vulnerability in Apache Struts, published on 16 Jul 2015.
Official description
The default exclude patterns (excludeParams) in Apache Struts 2.3.20 allow remote attackers to "compromise internal state of an application" via unspecified vectors.
Which versions are affected by CVE-2015-1831?
4 open source packages ship an affected version, including org.apache.struts.xwork:xwork-core and org.apache.struts:struts2-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts.xwork:xwork-core Maven | From 2.0.0 | 2.3.20.1 |
org.apache.struts.xwork:xwork-core Maven | From 2.0.0 | 2.3.20.1 |
org.apache.struts:struts2-core Maven | From 2.0.0 | 2.3.20.1 |
org.apache.struts:struts2-core Maven | From 2.0.0 | 2.3.20.1 |
Products include Apache Struts.
How do I fix CVE-2015-1831?
Upgrade org.apache.struts.xwork:xwork-core to 2.3.20.1 or later.
Is CVE-2015-1831 being exploited?
There is no known exploitation of CVE-2015-1831 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-q2cg-xf9p-h457.