# CVE-2015-1831: Incomplete exclude pattern in Apache Struts


- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 16 Jul 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-q2cg-xf9p-h457

## What is CVE-2015-1831?

CVE-2015-1831 is a high-severity vulnerability in Apache Struts, published on 16 Jul 2015. 

### Official description

The default exclude patterns (excludeParams) in Apache Struts 2.3.20 allow remote attackers to "compromise internal state of an application" via unspecified vectors.

## Which versions are affected by CVE-2015-1831?

4 open source packages ship an affected version, including org.apache.struts.xwork:xwork-core and org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts.xwork:xwork-core` | Maven | From 2.0.0 | 2.3.20.1 |
| `org.apache.struts.xwork:xwork-core` | Maven | From 2.0.0 | 2.3.20.1 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.20.1 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.20.1 |

Products: Apache Struts.

## How do I fix CVE-2015-1831?

Upgrade org.apache.struts.xwork:xwork-core to 2.3.20.1 or later.

## Is CVE-2015-1831 being exploited?

There is no known exploitation of CVE-2015-1831 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1831 and fix it if it is affected.

What it is: CVE-2015-1831 is a high-severity vulnerability in Apache Struts, published on 16 Jul 2015. 
Exploitation: There is no known exploitation of CVE-2015-1831 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts.xwork:xwork-core (Maven): affected from 2.0.0; fixed in 2.3.20.1
- org.apache.struts.xwork:xwork-core (Maven): affected from 2.0.0; fixed in 2.3.20.1
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.20.1
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1831/ (Markdown: https://insights.sbomify.com/CVE-2015-1831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1831
- OSV: https://osv.dev/vulnerability/CVE-2015-1831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1831/
Summaries are generated and may contain mistakes; the official description above is the record.
