{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.derby:derby. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-1832 in the wild and no public exploit code.","fix":"Upgrade org.apache.derby:derby to 10.12.1.1 or later.","what":"CVE-2015-1832 is a critical vulnerability in n/a, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-1832 and fix it if it is affected.\n\nWhat it is: CVE-2015-1832 is a critical vulnerability in n/a, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-1832 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.derby:derby (Maven): affected all versions; fixed in 10.12.1.1\n- org.apache.derby:derby (Maven): affected all versions; fixed in 10.12.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1832/ (Markdown: https://insights.sbomify.com/CVE-2015-1832/index.md)","id":"CVE-2015-1832","markdown":"https://insights.sbomify.com/CVE-2015-1832/index.md","name":"CVE-2015-1832","record":{"aliases":["DEBIAN-CVE-2015-1832","GHSA-wr69-g62g-2r9h","MGASA-2016-0385","UBUNTU-CVE-2015-1832"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Derby","requires_auth":"none","summary":"Attackers can read arbitrary files or cause denial of service via XML external entity injection in Apache Derby when Java Security Manager is disabled.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"derby","vendor":"apache"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"},{"id":"CWE-399","name":null}],"description":"XML external entity (XXE) vulnerability in the SqlXmlUtil code in Apache Derby before 10.12.1.1, when a Java Security Manager is not in place, allows context-dependent attackers to read arbitrary files or cause a denial of service (resource consumption) via vectors involving XmlVTI and the XML datatype.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Restriction of XML External Entity Reference in Apace Derby","id":"CVE-2015-1832","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2015"},"n_packages":2,"n_references":13,"next":{"headline":"Improper Input Validation in Apache Jackrabbit","id":"CVE-2015-1833"},"packages":[{"ecosystem":"Maven","fixed":["10.12.1.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.derby:derby","purl":null,"source":"GHSA-wr69-g62g-2r9h"},{"ecosystem":"Maven","fixed":["10.12.1.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.derby:derby","purl":"pkg:maven/org.apache.derby/derby","source":"GHSA-wr69-g62g-2r9h"}],"prev":{"headline":"Incomplete exclude pattern in Apache Struts","id":"CVE-2015-1831"},"products":["n/a"],"published":"2016-10-03","related":[{"cvss_score":9.8,"headline":"Apache Derby: LDAP injection vulnerability in authenticator","id":"CVE-2022-46337","kev_date_added":null,"published":"2023-11-20"},{"cvss_score":7.5,"headline":"Improper Access Control in Apache Derby","id":"CVE-2010-2232","kev_date_added":null,"published":"2017-10-23"},{"cvss_score":5.3,"headline":"Improper Access Control in Apache Derby","id":"CVE-2018-1313","kev_date_added":null,"published":"2018-05-07"},{"cvss_score":5,"headline":"Apache Derby exposes user and password attributes","id":"CVE-2005-4849","kev_date_added":null,"published":"2007-07-05"},{"cvss_score":4,"headline":"Missing authorization in n/a","id":"CVE-2006-7216","kev_date_added":null,"published":"2007-07-05"},{"cvss_score":4,"headline":"Apache Derby SQL Injection","id":"CVE-2006-7217","kev_date_added":null,"published":"2007-07-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can read arbitrary files or cause denial of service via XML external entity injection in Apache Derby when Java Security Manager is disabled.","url":"https://insights.sbomify.com/CVE-2015-1832/"}