# CVE-2015-1832: Improper Restriction of XML External Entity Reference in Apace Derby

> Attackers can read arbitrary files or cause denial of service via XML external entity injection in Apache Derby when Java Security Manager is disabled.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-1832, GHSA-wr69-g62g-2r9h, MGASA-2016-0385, UBUNTU-CVE-2015-1832

## What is CVE-2015-1832?

CVE-2015-1832 is a critical vulnerability in n/a, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XML external entity (XXE) vulnerability in the SqlXmlUtil code in Apache Derby before 10.12.1.1, when a Java Security Manager is not in place, allows context-dependent attackers to read arbitrary files or cause a denial of service (resource consumption) via vectors involving XmlVTI and the XML datatype.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference), CWE-399

## Which versions are affected by CVE-2015-1832?

2 open source packages ship an affected version, including org.apache.derby:derby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.derby:derby` | Maven | All versions | 10.12.1.1 |
| `org.apache.derby:derby` | Maven | All versions | 10.12.1.1 |

Products: Apache Derby.

## How do I fix CVE-2015-1832?

Upgrade org.apache.derby:derby to 10.12.1.1 or later.

## Is CVE-2015-1832 being exploited?

There is no known exploitation of CVE-2015-1832 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-46337](https://insights.sbomify.com/CVE-2022-46337/): Apache Derby: LDAP injection vulnerability in authenticator (critical 9.8)
- [CVE-2010-2232](https://insights.sbomify.com/CVE-2010-2232/): Improper Access Control in Apache Derby (high 7.5)
- [CVE-2018-1313](https://insights.sbomify.com/CVE-2018-1313/): Improper Access Control in Apache Derby (medium 5.3)
- [CVE-2005-4849](https://insights.sbomify.com/CVE-2005-4849/): Apache Derby exposes user and password attributes (medium 5.0)
- [CVE-2006-7216](https://insights.sbomify.com/CVE-2006-7216/): Missing authorization in n/a (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1832 and fix it if it is affected.

What it is: CVE-2015-1832 is a critical vulnerability in n/a, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-1832 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.derby:derby (Maven): affected all versions; fixed in 10.12.1.1
- org.apache.derby:derby (Maven): affected all versions; fixed in 10.12.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1832/ (Markdown: https://insights.sbomify.com/CVE-2015-1832/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1832
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1832
- OSV: https://osv.dev/vulnerability/CVE-2015-1832

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1832/
Summaries are generated and may contain mistakes; the official description above is the record.
