# CVE-2015-1836: High severity vulnerability that affects org.apache.hbase:hbase

> Remote attackers can cause denial of service, read sensitive data, or modify data due to incorrect ZooKeeper ACLs in Apache HBase.

- **Severity:** High 7.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Dec 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p8xr-4v2c-rvgp

## What is CVE-2015-1836?

CVE-2015-1836 is a high-severity missing authorization vulnerability in n/a, published on 21 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache HBase 0.98 before 0.98.12.1, 1.0 before 1.0.1.1, and 1.1 before 1.1.0.1, as used in IBM InfoSphere BigInsights 3.0, 3.0.0.1, and 3.0.0.2 and other products, uses incorrect ACLs for ZooKeeper coordination state, which allows remote attackers to cause a denial of service (daemon outage), obtain sensitive information, or modify data via unspecified client traffic.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2015-1836?

6 open source packages ship an affected version, including org.apache.hbase:hbase. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hbase:hbase` | Maven | From 0.98 | 0.98.12.1 |
| `org.apache.hbase:hbase` | Maven | From 0.98 | 0.98.12.1 |
| `org.apache.hbase:hbase` | Maven | From 1.0.0 | 1.0.1.1 |
| `org.apache.hbase:hbase` | Maven | From 1.0.0 | 1.0.1.1 |
| `org.apache.hbase:hbase` | Maven | From 1.1.0 | 1.1.0.1 |
| `org.apache.hbase:hbase` | Maven | From 1.1.0 | 1.1.0.1 |

Products: Apache Hbase, Ibm Infosphere Biginsights.

## How do I fix CVE-2015-1836?

Upgrade org.apache.hbase:hbase to a fixed version for your release line: 0.98.12.1, 1.0.1.1 or 1.1.0.1.

## Is CVE-2015-1836 being exploited?

There is no known exploitation of CVE-2015-1836 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-8025](https://insights.sbomify.com/CVE-2018-8025/): Race condition in org.apache.hbase:hbase-thrift (high 8.1)
- [CVE-2019-15544](https://insights.sbomify.com/CVE-2019-15544/): Uncontrolled memory consumption in protobuf (high 7.5)
- [CVE-2019-0212](https://insights.sbomify.com/CVE-2019-0212/): Improper Authorization in org.apache.hbase:hbase (high 7.5)
- [CVE-2026-49326](https://insights.sbomify.com/CVE-2026-49326/): Apache HBase: Missing scanner instance owner check in thrift delegation service (medium 6.5)
- [CVE-2013-2193](https://insights.sbomify.com/CVE-2013-2193/): Security feature bypass in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1836 and fix it if it is affected.

What it is: CVE-2015-1836 is a high-severity missing authorization vulnerability in n/a, published on 21 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-1836 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hbase:hbase (Maven): affected from 0.98; fixed in 0.98.12.1
- org.apache.hbase:hbase (Maven): affected from 0.98; fixed in 0.98.12.1
- org.apache.hbase:hbase (Maven): affected from 1.0.0; fixed in 1.0.1.1
- org.apache.hbase:hbase (Maven): affected from 1.0.0; fixed in 1.0.1.1
- org.apache.hbase:hbase (Maven): affected from 1.1.0; fixed in 1.1.0.1
- org.apache.hbase:hbase (Maven): affected from 1.1.0; fixed in 1.1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1836/ (Markdown: https://insights.sbomify.com/CVE-2015-1836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1836
- OSV: https://osv.dev/vulnerability/CVE-2015-1836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1836/
Summaries are generated and may contain mistakes; the official description above is the record.
