CVE-2015-1840 jquery-rails and jquery-ujs subject to Exposure of Sensitive Information
Remote attackers can bypass Same Origin Policy and leak CSRF tokens to external servers via crafted URLs in Ruby on Rails applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-1840?
CVE-2015-1840 is a medium-severity vulnerability in Fedoraproject Fedora, published on 26 Jul 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
jquery_ujs.js in jquery-rails before 3.1.3 and 4.x before 4.0.4 and rails.js in jquery-ujs before 1.0.4, as used with Ruby on Rails 3.x and 4.x, allow remote attackers to bypass the Same Origin Policy, and trigger transmission of a CSRF token to a different-domain web server, via a leading space character in a URL within an attribute value.
Weakness: CWE-200
Which versions are affected by CVE-2015-1840?
6 open source packages ship an affected version, including jquery-rails and jquery-ujs. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
jquery-rails RubyGems | All versions | 3.1.3 |
jquery-rails RubyGems | All versions | 3.1.3 |
jquery-rails RubyGems | From 4.0.0 | 4.0.4 |
jquery-rails RubyGems | From 4.0.0 | 4.0.4 |
jquery-ujs RubyGems | All versions | 1.0.4 |
jquery-ujs RubyGems | All versions | 1.0.4 |
Linux distribution packages (5)
ruby3.2-rubygem-jquery-rails openSUSE:Tumbleweed | All versions | 4.5.1-1.3 |
rubygem-jquery-rails openSUSE:Tumbleweed | All versions | 4.5.0-1.1 |
rubygem-jquery-rails openSUSE:Tumbleweed | All versions | 4.6.0-1.5 |
rubygem-jquery-rails openSUSE:Tumbleweed | All versions | 4.6.0-1.7 |
rubygem-jquery-rails openSUSE:Tumbleweed | All versions | 4.6.0-1.9 |
Products include Fedoraproject Fedora, Opensuse Opensuse, Rubyonrails Jquery-Rails, Rubyonrails Jquery-Ujs.
How do I fix CVE-2015-1840?
Upgrade jquery-rails to a fixed version for your release line: 3.1.3 or 4.0.4.
Is CVE-2015-1840 being exploited?
There is no known exploitation of CVE-2015-1840 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as DEBIAN-CVE-2015-1840, GHSA-4whc-pp4x-9pf3, openSUSE-SU-2024:10512-1, openSUSE-SU-2024:11334-1, openSUSE-SU-2024:12144-1, openSUSE-SU-2024:13159-1 and 3 more.