# CVE-2015-1851: OpenStack Cinder file disclosure in image convert

> Authenticated users can read arbitrary files on the server by uploading a crafted qcow2 image to OpenStack Cinder.

- **Severity:** Medium 6.8 (`AV:N/AC:L/Au:S/C:C/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-1851, DSA-3292-1, GHSA-9hcj-h2qc-689p, PYSEC-2026-789, RHSA-2015:1206

## What is CVE-2015-1851?

CVE-2015-1851 is a medium-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 25 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Cinder before 2014.1.5 (icehouse), 2014.2.x before 2014.2.4 (juno), and 2015.1.x before 2015.1.1 (kilo) allows remote authenticated users to read arbitrary files via a crafted qcow2 signature in an image to the upload-to-image command.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-1851?

3 open source packages ship an affected version, including cinder. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cinder` | PyPI | All versions | 7.0.0a0 |
| `cinder` | PyPI | All versions | 7.0.0a0 |
| `cinder` | PyPI | All versions | 7.0.0a0 |
| `openstack-cinder` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.4-1.1.el6ost |
| `openstack-cinder-doc` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.4-1.1.el6ost |
| `python-cinder` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.4-1.1.el6ost |
| `openstack-cinder` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.4-1.1.el7ost |
| `openstack-cinder-doc` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.4-1.1.el7ost |
| `python-cinder` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.4-1.1.el7ost |
| `openstack-cinder` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-3.1.el7ost |
| `openstack-cinder-doc` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-3.1.el7ost |
| `python-cinder` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-3.1.el7ost |

Products: Canonical Ubuntu Linux, Openstack Icehouse, Openstack Juno, Openstack Kilo.

## How do I fix CVE-2015-1851?

Upgrade cinder to 7.0.0a0 or later.

## Is CVE-2015-1851 being exploited?

There is no known exploitation of CVE-2015-1851 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1851 and fix it if it is affected.

What it is: CVE-2015-1851 is a medium-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 25 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-1851 in the wild and no public exploit code.

Affected packages and fixed versions:
- cinder (PyPI): affected all versions; fixed in 7.0.0a0
- cinder (PyPI): affected all versions; fixed in 7.0.0a0
- cinder (PyPI): affected all versions; fixed in 7.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1851/ (Markdown: https://insights.sbomify.com/CVE-2015-1851/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1851
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1851
- OSV: https://osv.dev/vulnerability/CVE-2015-1851

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1851/
Summaries are generated and may contain mistakes; the official description above is the record.
