# CVE-2015-1856: OpenStack Swift Unauthorized delete of versioned Swift object

> Authenticated users can delete the latest version of an object in OpenStack Swift when versioning is enabled, leading to unauthorized data modification.

- **Severity:** Medium 5.5 (`AV:N/AC:L/Au:S/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-1856, GHSA-cc77-5vw4-7pwg, PYSEC-2026-931, RHSA-2015:1681, RHSA-2015:1684, UBUNTU-CVE-2015-1856

## What is CVE-2015-1856?

CVE-2015-1856 is a medium-severity missing authorization vulnerability in Canonical Ubuntu Linux, published on 17 Apr 2015. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Object Storage (Swift) before 2.3.0, when allow_version is configured, allows remote authenticated users to delete the latest version of an object by leveraging listing access to the x-versions-location container.

Weakness: CWE-264

## Which versions are affected by CVE-2015-1856?

3 open source packages ship an affected version, including swift. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swift` | PyPI | All versions | 2.3.0 |
| `swift` | PyPI | All versions | 2.3.0 |
| `swift` | PyPI | All versions | 2.3.0 |
| `openstack-swift` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-6.el6ost |
| `openstack-swift-account` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-6.el6ost |
| `openstack-swift-container` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-6.el6ost |
| `openstack-swift-doc` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-6.el6ost |
| `openstack-swift-object` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-6.el6ost |
| `openstack-swift-proxy` | Red Hat:openstack:5::el6 | All versions | 0:1.13.1-6.el6ost |
| `openstack-swift` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-5.el7ost |
| `openstack-swift-account` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-5.el7ost |
| `openstack-swift-container` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-5.el7ost |
| `openstack-swift-doc` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-5.el7ost |
| `openstack-swift-object` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-5.el7ost |
| `openstack-swift-proxy` | Red Hat:openstack:5::el7 | All versions | 0:1.13.1-5.el7ost |
| `openstack-swift` | Red Hat:openstack:6::el7 | All versions | 0:2.2.0-4.el7ost |
| `openstack-swift-account` | Red Hat:openstack:6::el7 | All versions | 0:2.2.0-4.el7ost |
| `openstack-swift-container` | Red Hat:openstack:6::el7 | All versions | 0:2.2.0-4.el7ost |
| `openstack-swift-doc` | Red Hat:openstack:6::el7 | All versions | 0:2.2.0-4.el7ost |
| `openstack-swift-object` | Red Hat:openstack:6::el7 | All versions | 0:2.2.0-4.el7ost |
| `openstack-swift-proxy` | Red Hat:openstack:6::el7 | All versions | 0:2.2.0-4.el7ost |

Products: Canonical Ubuntu Linux, Openstack Swift.

## How do I fix CVE-2015-1856?

Upgrade swift to 2.3.0 or later.

## Is CVE-2015-1856 being exploited?

There is no known exploitation of CVE-2015-1856 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1856 and fix it if it is affected.

What it is: CVE-2015-1856 is a medium-severity missing authorization vulnerability in Canonical Ubuntu Linux, published on 17 Apr 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-1856 in the wild and no public exploit code.

Affected packages and fixed versions:
- swift (PyPI): affected all versions; fixed in 2.3.0
- swift (PyPI): affected all versions; fixed in 2.3.0
- swift (PyPI): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1856/ (Markdown: https://insights.sbomify.com/CVE-2015-1856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1856
- OSV: https://osv.dev/vulnerability/CVE-2015-1856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1856/
Summaries are generated and may contain mistakes; the official description above is the record.
