{"answers":{"affected":"3 open source packages ship an affected version, including kallithea and Kallithea. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-1864 in the wild and no public exploit code.","fix":"Upgrade kallithea to 0.2.1 or later.","what":"CVE-2015-1864 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Sep 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-1864 and fix it if it is affected.\n\nWhat it is: CVE-2015-1864 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Sep 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-1864 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kallithea (PyPI): affected all versions; fixed in 0.2.1\n- kallithea (PyPI): affected all versions; fixed in 0.2.1\n- Kallithea (PyPI): affected all versions; fixed in 0.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-1864/ (Markdown: https://insights.sbomify.com/CVE-2015-1864/index.md)","id":"CVE-2015-1864","markdown":"https://insights.sbomify.com/CVE-2015-1864/index.md","name":"CVE-2015-1864","record":{"aliases":["GHSA-fh5c-7gmg-xmp6","PYSEC-2017-17"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Kallithea SCM","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script or HTML via user details and description fields in Kallithea administration pages.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"kallithea","vendor":"kallithea-scm"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in the administration pages in Kallithea before 0.2.1 allow remote attackers to inject arbitrary web script or HTML via the (1) first name or (2) last name user details, or the (3) repository, (4) repository group, or (5) user group description.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kallithea cross-site scripting (XSS) vulnerability","id":"CVE-2015-1864","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2015"},"n_packages":3,"n_references":4,"next":{"headline":"Race condition in n/a","id":"CVE-2015-1865"},"packages":[{"ecosystem":"PyPI","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"Kallithea","purl":null,"source":"GHSA-fh5c-7gmg-xmp6"},{"ecosystem":"PyPI","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"kallithea","purl":"pkg:pypi/kallithea","source":"GHSA-fh5c-7gmg-xmp6"},{"ecosystem":"PyPI","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"kallithea","purl":"pkg:pypi/kallithea","source":"PYSEC-2017-17"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2015-1863"},"products":["n/a"],"published":"2017-09-19","related":[{"cvss_score":8.8,"headline":"Kallithea cross-site request forgery (CSRF) vulnerability","id":"CVE-2015-0276","kev_date_added":null,"published":"2017-09-21"},{"cvss_score":8.8,"headline":"Kallithea Routes CSRF Bypass","id":"CVE-2016-3691","kev_date_added":null,"published":"2017-04-24"},{"cvss_score":5,"headline":"Kallithea CRLF injection vulnerability","id":"CVE-2015-5285","kev_date_added":null,"published":"2015-10-29"},{"cvss_score":4,"headline":"RhodeCode and Kallithea are vulnerable to sensitive information disclosure","id":"CVE-2015-0260","kev_date_added":null,"published":"2015-02-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via user details and description fields in Kallithea administration pages.","url":"https://insights.sbomify.com/CVE-2015-1864/"}