# CVE-2015-1864: Kallithea cross-site scripting (XSS) vulnerability

> Remote attackers can inject arbitrary web script or HTML via user details and description fields in Kallithea administration pages.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Sep 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-fh5c-7gmg-xmp6, PYSEC-2017-17

## What is CVE-2015-1864?

CVE-2015-1864 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Sep 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in the administration pages in Kallithea before 0.2.1 allow remote attackers to inject arbitrary web script or HTML via the (1) first name or (2) last name user details, or the (3) repository, (4) repository group, or (5) user group description.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-1864?

3 open source packages ship an affected version, including kallithea and Kallithea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kallithea` | PyPI | All versions | 0.2.1 |
| `kallithea` | PyPI | All versions | 0.2.1 |
| `Kallithea` | PyPI | All versions | 0.2.1 |

Products: Kallithea-Scm Kallithea.

## How do I fix CVE-2015-1864?

Upgrade kallithea to 0.2.1 or later.

## Is CVE-2015-1864 being exploited?

There is no known exploitation of CVE-2015-1864 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-0276](https://insights.sbomify.com/CVE-2015-0276/): Kallithea cross-site request forgery (CSRF) vulnerability (high 8.8)
- [CVE-2016-3691](https://insights.sbomify.com/CVE-2016-3691/): Kallithea Routes CSRF Bypass (high 8.8)
- [CVE-2015-5285](https://insights.sbomify.com/CVE-2015-5285/): Kallithea CRLF injection vulnerability (medium 5.0)
- [CVE-2015-0260](https://insights.sbomify.com/CVE-2015-0260/): RhodeCode and Kallithea are vulnerable to sensitive information disclosure (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-1864 and fix it if it is affected.

What it is: CVE-2015-1864 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Sep 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-1864 in the wild and no public exploit code.

Affected packages and fixed versions:
- kallithea (PyPI): affected all versions; fixed in 0.2.1
- kallithea (PyPI): affected all versions; fixed in 0.2.1
- Kallithea (PyPI): affected all versions; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-1864/ (Markdown: https://insights.sbomify.com/CVE-2015-1864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-1864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-1864
- OSV: https://osv.dev/vulnerability/CVE-2015-1864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-1864/
Summaries are generated and may contain mistakes; the official description above is the record.
