CVE-2015-1866 ember-source vulnerable to Cross-site Scripting
Cross-site scripting vulnerability in Ember.js allows attackers to inject malicious scripts into web pages viewed by other users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-1866?
CVE-2015-1866 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.
Weakness: CWE-79
Which versions are affected by CVE-2015-1866?
4 open source packages ship an affected version, including ember-source. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
ember-source RubyGems | From 1.10.0 | 1.10.1 |
ember-source RubyGems | From 1.10.0 | 1.10.1 |
ember-source RubyGems | From 1.11.0 | 1.11.2 |
ember-source RubyGems | From 1.11.0 | 1.11.2 |
Products include Emberjs Ember.js.
How do I fix CVE-2015-1866?
Upgrade ember-source to a fixed version for your release line: 1.10.1 or 1.11.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2015-1866 being exploited?
There is no known exploitation of CVE-2015-1866 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2013-4170 Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data
- CVE-2015-7565 ember-source Cross-site Scripting vulnerability
- CVE-2014-0013 Ember.js Cross-site Scripting vulnerability
- CVE-2014-0014 ember-source Cross-site Scripting vulnerability
- CVE-2014-0046 ember-source Cross-site Scripting vulnerability
Sources
Also known as GHSA-mp78-r56v-45qc.