{"answers":{"affected":"2 open source packages ship an affected version, including ruby-saml. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-20108 in the wild and no public exploit code.","fix":"Upgrade ruby-saml to 1.0.0 or later.","what":"CVE-2015-20108 is a critical code injection vulnerability in n/a, published on 27 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-20108 and fix it if it is affected.\n\nWhat it is: CVE-2015-20108 is a critical code injection vulnerability in n/a, published on 27 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-20108 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ruby-saml (RubyGems): affected all versions; fixed in 1.0.0\n- ruby-saml (RubyGems): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-20108/ (Markdown: https://insights.sbomify.com/CVE-2015-20108/index.md)","id":"CVE-2015-20108","markdown":"https://insights.sbomify.com/CVE-2015-20108/index.md","name":"CVE-2015-20108","record":{"aliases":["DEBIAN-CVE-2015-20108","GHSA-r364-2pj4-pf7f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby SAML library","requires_auth":"none","summary":"Attackers can execute arbitrary code via XPath injection in the ruby-saml gem due to lack of prepared statements.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ruby-saml","vendor":"onelogin"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ruby-saml vulnerable to XPath injection","id":"CVE-2015-20108","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"code_injection","year":"2015"},"n_packages":2,"n_references":5,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-20109"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":null,"source":"GHSA-r364-2pj4-pf7f"},{"ecosystem":"RubyGems","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":"pkg:gem/ruby-saml","source":"GHSA-r364-2pj4-pf7f"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2015-20107"},"products":["n/a"],"published":"2023-05-27","related":[{"cvss_score":9.3,"headline":"ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)","id":"CVE-2025-66567","kev_date_added":null,"published":"2025-12-09"},{"cvss_score":9.3,"headline":"ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation","id":"CVE-2025-66568","kev_date_added":null,"published":"2025-12-09"},{"cvss_score":7.7,"headline":"Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal","id":"CVE-2017-11428","kev_date_added":null,"published":"2019-04-17"},{"cvss_score":7.5,"headline":"Ruby-saml allows attackers to perform XML signature wrapping attacks","id":"CVE-2016-5697","kev_date_added":null,"published":"2017-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-14","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via XPath injection in the ruby-saml gem due to lack of prepared statements.","url":"https://insights.sbomify.com/CVE-2015-20108/"}