# CVE-2015-20108: ruby-saml vulnerable to XPath injection

> Attackers can execute arbitrary code via XPath injection in the ruby-saml gem due to lack of prepared statements.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2023
- **Updated:** 14 Jan 2025
- **Also known as:** DEBIAN-CVE-2015-20108, GHSA-r364-2pj4-pf7f

## What is CVE-2015-20108?

CVE-2015-20108 is a critical code injection vulnerability in n/a, published on 27 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2015-20108?

2 open source packages ship an affected version, including ruby-saml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby-saml` | RubyGems | All versions | 1.0.0 |
| `ruby-saml` | RubyGems | All versions | 1.0.0 |

Products: Onelogin Ruby-Saml.

## How do I fix CVE-2015-20108?

Upgrade ruby-saml to 1.0.0 or later.

## Is CVE-2015-20108 being exploited?

There is no known exploitation of CVE-2015-20108 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-66567](https://insights.sbomify.com/CVE-2025-66567/): ruby-saml has a SAML authentication bypass due to namespace handling (parser differential) (critical 9.3)
- [CVE-2025-66568](https://insights.sbomify.com/CVE-2025-66568/): ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation (critical 9.3)
- [CVE-2017-11428](https://insights.sbomify.com/CVE-2017-11428/): Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal (high 7.7)
- [CVE-2016-5697](https://insights.sbomify.com/CVE-2016-5697/): Ruby-saml allows attackers to perform XML signature wrapping attacks (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-20108 and fix it if it is affected.

What it is: CVE-2015-20108 is a critical code injection vulnerability in n/a, published on 27 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-20108 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby-saml (RubyGems): affected all versions; fixed in 1.0.0
- ruby-saml (RubyGems): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-20108/ (Markdown: https://insights.sbomify.com/CVE-2015-20108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-20108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-20108
- OSV: https://osv.dev/vulnerability/CVE-2015-20108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-20108/
Summaries are generated and may contain mistakes; the official description above is the record.
