# CVE-2015-20110: generator-jhipster allows a timing attack against validateToken due to a string comparison that stops at the first character

> Attackers can bypass token validation in JHipster generator via timing attacks, allowing them to guess valid tokens and potentially access protected resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2023
- **Updated:** 6 Sep 2024
- **Also known as:** GHSA-4gpm-r23h-gprw

## What is CVE-2015-20110?

CVE-2015-20110 is a high-severity vulnerability in n/a, published on 31 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JHipster generator-jhipster before 2.23.0 allows a timing attack against validateToken due to a string comparison that stops at the first character that is different. Attackers can guess tokens by brute forcing one character at a time and observing the timing. This of course drastically reduces the search space to a linear amount of guesses based on the token length times the possible characters.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2015-20110?

2 open source packages ship an affected version, including generator-jhipster. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `generator-jhipster` | npm | All versions | 2.23.0 |
| `generator-jhipster` | npm | All versions | 2.23.0 |

Products: Jhipster Jhipster.

## How do I fix CVE-2015-20110?

Upgrade generator-jhipster to 2.23.0 or later.

## Is CVE-2015-20110 being exploited?

There is no known exploitation of CVE-2015-20110 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-16303](https://insights.sbomify.com/CVE-2019-16303/): JHipster Kotlin using insecure source of randomness `RandomStringUtils` before v1.2.0 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-20110 and fix it if it is affected.

What it is: CVE-2015-20110 is a high-severity vulnerability in n/a, published on 31 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-20110 in the wild and no public exploit code.

Affected packages and fixed versions:
- generator-jhipster (npm): affected all versions; fixed in 2.23.0
- generator-jhipster (npm): affected all versions; fixed in 2.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-20110/ (Markdown: https://insights.sbomify.com/CVE-2015-20110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-20110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-20110
- OSV: https://osv.dev/vulnerability/CVE-2015-20110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-20110/
Summaries are generated and may contain mistakes; the official description above is the record.
