{"answers":{"affected":"2 open source packages ship an affected version, including dweeves/magmi. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-2068 exists.","fix":"Upgrade dweeves/magmi to 0.7.22 or later.","what":"CVE-2015-2068 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Feb 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-2068 and fix it if it is affected.\n\nWhat it is: CVE-2015-2068 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Feb 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-2068 exists.\n\nAffected packages and fixed versions:\n- dweeves/magmi (Packagist): affected all versions; fixed in 0.7.22\n- dweeves/magmi (Packagist): affected all versions; fixed in 0.7.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-2068/ (Markdown: https://insights.sbomify.com/CVE-2015-2068/index.md)","id":"CVE-2015-2068","markdown":"https://insights.sbomify.com/CVE-2015-2068/index.md","name":"CVE-2015-2068","record":{"aliases":["GHSA-27v2-398x-f74x"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento importer plugin","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script or HTML via specific parameters in the MAGMI plugin for Magento, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"magmi","vendor":"magmi_project"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in the MAGMI (aka Magento Mass Importer) plugin for Magento Server allow remote attackers to inject arbitrary web script or HTML via the (1) profile parameter to web/magmi.php or (2) QUERY_STRING to web/magmi_import_run.php.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2015-02-05","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":"2015-02-05","kind":"exploitdb","ref":"35996","stars":null,"title":"Magento Server MAGMI Plugin - Multiple Vulnerabilities"},{"date":null,"kind":"nuclei","ref":"http/cves/2015/CVE-2015-2068.yaml","stars":null,"title":"Magento Server Mass Importer - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"MAGMI cross-site scripting (XSS)","id":"CVE-2015-2068","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-2069"},"packages":[{"ecosystem":"Packagist","fixed":["0.7.22"],"introduced":["0"],"last_affected":[],"package":"dweeves/magmi","purl":null,"source":"GHSA-27v2-398x-f74x"},{"ecosystem":"Packagist","fixed":["0.7.22"],"introduced":["0"],"last_affected":[],"package":"dweeves/magmi","purl":"pkg:composer/dweeves/magmi","source":"GHSA-27v2-398x-f74x"}],"prev":{"headline":"MAGMI plugin for Magento Server Directory Traversal","id":"CVE-2015-2067"},"products":["n/a"],"published":"2015-02-24","related":[{"cvss_score":9.8,"headline":"Authentication bypass in MAGMI","id":"CVE-2020-5777","kev_date_added":null,"published":"2020-09-01"},{"cvss_score":9,"headline":"MAGMI plugin for Magento Unsafe File Upload","id":"CVE-2014-8770","kev_date_added":null,"published":"2014-11-13"},{"cvss_score":8.8,"headline":"Cross-Site Request Forgery in MAGMI","id":"CVE-2020-5776","kev_date_added":null,"published":"2020-09-01"},{"cvss_score":6.1,"headline":"Magmi XSS Vulnerability","id":"CVE-2017-7391","kev_date_added":null,"published":"2017-04-01"},{"cvss_score":5,"headline":"MAGMI plugin for Magento Server Directory Traversal","id":"CVE-2015-2067","kev_date_added":null,"published":"2015-02-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via specific parameters in the MAGMI plugin for Magento, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2015-2068/"}