# CVE-2015-2080: Jetty vulnerable to exposure of sensitive information to unauthenticated remote users

> Remote attackers can obtain sensitive process memory information via illegal characters in HTTP headers, affecting Jetty web server deployments.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-ghgj-3xqr-6jfm

## What is CVE-2015-2080?

CVE-2015-2080 is a high-severity vulnerability in Eclipse Jetty, published on 7 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The exception handling code in Eclipse Jetty before 9.2.9.v20150224 allows remote attackers to obtain sensitive information from process memory via illegal characters in an HTTP header, aka JetLeak.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-2080?

2 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | All versions | 9.2.9.v20150224 |
| `org.eclipse.jetty:jetty-server` | Maven | All versions | 9.2.9.v20150224 |

Products: Eclipse Jetty, Fedoraproject Fedora.

## How do I fix CVE-2015-2080?

Upgrade org.eclipse.jetty:jetty-server to 9.2.9.v20150224 or later.

## Is CVE-2015-2080 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-2080 exists.

Public exploit code:

- Inductive Automation Ignition 7.8.1 - Remote Leakage Of Shared Buffers (exploitdb)
- Eclipse Jetty <9.2.9.v20150224 - Sensitive Information Leakage (nuclei): http/cves/2015/CVE-2015-2080.yaml

## Other vulnerabilities in Eclipse Jetty

- [CVE-2016-4800](https://insights.sbomify.com/CVE-2016-4800/): Jetty contains an alias issue that could allow unauthenticated remote code execution due to specially crafted request (critical 9.8)
- [CVE-2019-17638](https://insights.sbomify.com/CVE-2019-17638/): Operation on a Resource after Expiration or Release in Jetty Server (critical 9.4)
- [CVE-2018-12538](https://insights.sbomify.com/CVE-2018-12538/): Access and integrity issue within Eclipse Jetty (high 8.8)
- [CVE-2026-10050](https://insights.sbomify.com/CVE-2026-10050/): Digest authentication lossy encoding (high 8.7)
- [CVE-2025-5115](https://insights.sbomify.com/CVE-2025-5115/): MadeYouReset HTTP/2 vulnerability (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-2080 and fix it if it is affected.

What it is: CVE-2015-2080 is a high-severity vulnerability in Eclipse Jetty, published on 7 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-2080 exists.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 9.2.9.v20150224
- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 9.2.9.v20150224

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-2080/ (Markdown: https://insights.sbomify.com/CVE-2015-2080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-2080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-2080
- OSV: https://osv.dev/vulnerability/CVE-2015-2080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-2080/
Summaries are generated and may contain mistakes; the official description above is the record.
