CVE-2015-2156 Information Exposure in Netty
Remote attackers can bypass httpOnly cookie flags to obtain sensitive information due to improper validation of cookie characters in Netty and Play Framework.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-2156?
CVE-2015-2156 is a high-severity vulnerability in Netty Netty, published on 18 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Netty before 3.9.8.Final, 3.10.x before 3.10.3.Final, 4.0.x before 4.0.28.Final, and 4.1.x before 4.1.0.Beta5 and Play Framework 2.x before 2.3.9 might allow remote attackers to bypass the httpOnly flag on cookies and obtain sensitive information by leveraging improper validation of cookie name and value characters.
Weakness: CWE-20
Which versions are affected by CVE-2015-2156?
10 open source packages ship an affected version, including io.netty:netty, io.netty:netty-parent and org.jboss.netty:netty. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
io.netty:netty Maven | All versions | 3.9.8.Final |
io.netty:netty Maven | All versions | 3.9.8.Final |
io.netty:netty Maven | From 3.10.0 | 3.10.3.Final |
io.netty:netty Maven | From 3.10.0 | 3.10.3.Final |
io.netty:netty-parent Maven | From 4.0.0 | 4.0.28.Final |
io.netty:netty-parent Maven | From 4.0.0 | 4.0.28.Final |
4 more packages
org.jboss.netty:netty Maven | All versions | 3.9.8.Final |
org.jboss.netty:netty Maven | All versions | 3.9.8.Final |
org.jboss.netty:netty Maven | From 3.10.0 | 3.10.3.Final |
org.jboss.netty:netty Maven | From 3.10.0 | 3.10.3.Final |
Products include Lightbend Play Framework, Netty Netty, Playframework Play Framework.
How do I fix CVE-2015-2156?
Upgrade io.netty:netty to a fixed version for your release line: 3.9.8.Final or 3.10.3.Final.
Is CVE-2015-2156 being exploited?
There is no known exploitation of CVE-2015-2156 in the wild and no public exploit code.
Other vulnerabilities in Netty Netty
Sources
Also known as DEBIAN-CVE-2015-2156, GHSA-xfv3-rrfm-f2rv, UBUNTU-CVE-2015-2156.