# CVE-2015-2156: Information Exposure in Netty

> Remote attackers can bypass httpOnly cookie flags to obtain sensitive information due to improper validation of cookie characters in Netty and Play Framework.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-2156, GHSA-xfv3-rrfm-f2rv, UBUNTU-CVE-2015-2156

## What is CVE-2015-2156?

CVE-2015-2156 is a high-severity vulnerability in Netty Netty, published on 18 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty before 3.9.8.Final, 3.10.x before 3.10.3.Final, 4.0.x before 4.0.28.Final, and 4.1.x before 4.1.0.Beta5 and Play Framework 2.x before 2.3.9 might allow remote attackers to bypass the httpOnly flag on cookies and obtain sensitive information by leveraging improper validation of cookie name and value characters.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2015-2156?

10 open source packages ship an affected version, including io.netty:netty, io.netty:netty-parent and org.jboss.netty:netty. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty` | Maven | All versions | 3.9.8.Final |
| `io.netty:netty` | Maven | All versions | 3.9.8.Final |
| `io.netty:netty` | Maven | From 3.10.0 | 3.10.3.Final |
| `io.netty:netty` | Maven | From 3.10.0 | 3.10.3.Final |
| `io.netty:netty-parent` | Maven | From 4.0.0 | 4.0.28.Final |
| `io.netty:netty-parent` | Maven | From 4.0.0 | 4.0.28.Final |
| `org.jboss.netty:netty` | Maven | All versions | 3.9.8.Final |
| `org.jboss.netty:netty` | Maven | All versions | 3.9.8.Final |
| `org.jboss.netty:netty` | Maven | From 3.10.0 | 3.10.3.Final |
| `org.jboss.netty:netty` | Maven | From 3.10.0 | 3.10.3.Final |

Products: Lightbend Play Framework, Netty Netty, Playframework Play Framework.

## How do I fix CVE-2015-2156?

Upgrade io.netty:netty to a fixed version for your release line: 3.9.8.Final or 3.10.3.Final.

## Is CVE-2015-2156 being exploited?

There is no known exploitation of CVE-2015-2156 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2014-3630](https://insights.sbomify.com/CVE-2014-3630/): XML external entity in n/a (critical 9.8)
- [CVE-2022-31018](https://insights.sbomify.com/CVE-2022-31018/): Denial of service binding form from JSON in Play Framework (high 7.5)
- [CVE-2020-26882](https://insights.sbomify.com/CVE-2020-26882/): Data Amplification in Play Framework (high 7.5)
- [CVE-2020-26883](https://insights.sbomify.com/CVE-2020-26883/): Uncontrolled Recursion in Play Framework (high 7.5)
- [CVE-2020-27196](https://insights.sbomify.com/CVE-2020-27196/): Out-of-bounds Write in Play Framework (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-2156 and fix it if it is affected.

What it is: CVE-2015-2156 is a high-severity vulnerability in Netty Netty, published on 18 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-2156 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty (Maven): affected all versions; fixed in 3.9.8.Final
- io.netty:netty (Maven): affected all versions; fixed in 3.9.8.Final
- io.netty:netty (Maven): affected from 3.10.0; fixed in 3.10.3.Final
- io.netty:netty (Maven): affected from 3.10.0; fixed in 3.10.3.Final
- io.netty:netty-parent (Maven): affected from 4.0.0; fixed in 4.0.28.Final
- io.netty:netty-parent (Maven): affected from 4.0.0; fixed in 4.0.28.Final
- org.jboss.netty:netty (Maven): affected all versions; fixed in 3.9.8.Final
- org.jboss.netty:netty (Maven): affected all versions; fixed in 3.9.8.Final
- org.jboss.netty:netty (Maven): affected from 3.10.0; fixed in 3.10.3.Final
- org.jboss.netty:netty (Maven): affected from 3.10.0; fixed in 3.10.3.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-2156/ (Markdown: https://insights.sbomify.com/CVE-2015-2156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-2156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-2156
- OSV: https://osv.dev/vulnerability/CVE-2015-2156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-2156/
Summaries are generated and may contain mistakes; the official description above is the record.
