CVE-2015-2241 Django Cross-site Scripting Vulnerability

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML into the Django admin interface via model attributes, requiring admin access to exploit.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-2241?

CVE-2015-2241 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 12 Mar 2015. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the contents function in admin/helpers.py in Django before 1.7.6 and 1.8 before 1.8b2 allows remote attackers to inject arbitrary web script or HTML via a model attribute in ModelAdmin.readonly_fields, as demonstrated by a @property.

Weakness: CWE-79

Which versions are affected by CVE-2015-2241?

5 open source packages ship an affected version, including django and Django. It affects 1 product.

PackageAffectedFixed in
django PyPIAll versions1.7.6, 1.8b2
django PyPIAll versions1.7.6
django PyPIFrom 1.8a11.8b2
Django PyPIAll versions1.7.6
Django PyPIFrom 1.8a11.8b2

Products include Djangoproject Django.

How do I fix CVE-2015-2241?

Upgrade django to a fixed version for your release line: 1.7.6 or 1.8b2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-2241 being exploited?

There is no known exploitation of CVE-2015-2241 in the wild and no public exploit code.

All Djangoproject Django vulnerabilities

Sources

Also known as DEBIAN-CVE-2015-2241, GHSA-6565-fg86-6jcx, PYSEC-2015-8.

Is CVE-2015-2241 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free