{"answers":{"affected":"5 open source packages ship an affected version, including django and Django. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-2241 in the wild and no public exploit code.","fix":"Upgrade django to a fixed version for your release line: 1.7.6 or 1.8b2.","what":"CVE-2015-2241 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 12 Mar 2015. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-2241 and fix it if it is affected.\n\nWhat it is: CVE-2015-2241 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 12 Mar 2015. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-2241 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- django (PyPI): affected all versions; fixed in 1.7.6, 1.8b2\n- django (PyPI): affected all versions; fixed in 1.7.6\n- django (PyPI): affected from 1.8a1; fixed in 1.8b2\n- Django (PyPI): affected all versions; fixed in 1.7.6\n- Django (PyPI): affected from 1.8a1; fixed in 1.8b2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-2241/ (Markdown: https://insights.sbomify.com/CVE-2015-2241/index.md)","id":"CVE-2015-2241","markdown":"https://insights.sbomify.com/CVE-2015-2241/index.md","name":"CVE-2015-2241","record":{"aliases":["DEBIAN-CVE-2015-2241","GHSA-6565-fg86-6jcx","PYSEC-2015-8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Django web framework","requires_auth":"high_privilege","summary":"Remote attackers can inject arbitrary web script or HTML into the Django admin interface via model attributes, requiring admin access to exploit.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"django","vendor":"djangoproject"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the contents function in admin/helpers.py in Django before 1.7.6 and 1.8 before 1.8b2 allows remote attackers to inject arbitrary web script or HTML via a model attribute in ModelAdmin.readonly_fields, as demonstrated by a @property.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Django Cross-site Scripting Vulnerability","id":"CVE-2015-2241","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"djangoproject:django","products":["djangoproject:django"],"type":"xss","year":"2015"},"n_packages":5,"n_references":4,"next":{"headline":"SQL injection in n/a","id":"CVE-2015-2242"},"packages":[{"ecosystem":"PyPI","fixed":["1.7.6"],"introduced":["0"],"last_affected":[],"package":"Django","purl":null,"source":"GHSA-6565-fg86-6jcx"},{"ecosystem":"PyPI","fixed":["1.8b2"],"introduced":["1.8a1"],"last_affected":[],"package":"Django","purl":null,"source":"GHSA-6565-fg86-6jcx"},{"ecosystem":"PyPI","fixed":["1.7.6","1.8b2"],"introduced":["0","1.8a1"],"last_affected":[],"package":"django","purl":"pkg:pypi/django","source":"PYSEC-2015-8"},{"ecosystem":"PyPI","fixed":["1.7.6"],"introduced":["0"],"last_affected":[],"package":"django","purl":"pkg:pypi/django","source":"GHSA-6565-fg86-6jcx"},{"ecosystem":"PyPI","fixed":["1.8b2"],"introduced":["1.8a1"],"last_affected":[],"package":"django","purl":"pkg:pypi/django","source":"GHSA-6565-fg86-6jcx"}],"prev":{"headline":"Other in n/a","id":"CVE-2015-2239"},"products":["n/a"],"published":"2015-03-12","related":[{"cvss_score":9.8,"headline":"Privilege abuse in GenericInlineModelAdmin","id":"CVE-2026-4277","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":9.8,"headline":"Django SQL injection in HasKey(lhs, rhs) on Oracle","id":"CVE-2024-53908","kev_date_added":null,"published":"2024-12-06"},{"cvss_score":9.8,"headline":"Django SQL injection vulnerability","id":"CVE-2024-42005","kev_date_added":null,"published":"2024-08-07"},{"cvss_score":9.8,"headline":"Django bypasses validation when using one form field to upload multiple files","id":"CVE-2023-31047","kev_date_added":null,"published":"2023-05-07"},{"cvss_score":9.8,"headline":"Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection","id":"CVE-2022-34265","kev_date_added":null,"published":"2022-07-04"},{"cvss_score":9.8,"headline":"SQL Injection in Django","id":"CVE-2021-35042","kev_date_added":null,"published":"2021-07-02"},{"cvss_score":9.8,"headline":"SQL injection in Django","id":"CVE-2020-7471","kev_date_added":null,"published":"2020-02-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into the Django admin interface via model attributes, requiring admin access to exploit.","url":"https://insights.sbomify.com/CVE-2015-2241/"}