# CVE-2015-2241: Django Cross-site Scripting Vulnerability

> Remote attackers can inject arbitrary web script or HTML into the Django admin interface via model attributes, requiring admin access to exploit.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Mar 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-2241, GHSA-6565-fg86-6jcx, PYSEC-2015-8

## What is CVE-2015-2241?

CVE-2015-2241 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 12 Mar 2015. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the contents function in admin/helpers.py in Django before 1.7.6 and 1.8 before 1.8b2 allows remote attackers to inject arbitrary web script or HTML via a model attribute in ModelAdmin.readonly_fields, as demonstrated by a @property.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-2241?

5 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | All versions | 1.7.6, 1.8b2 |
| `django` | PyPI | All versions | 1.7.6 |
| `django` | PyPI | From 1.8a1 | 1.8b2 |
| `Django` | PyPI | All versions | 1.7.6 |
| `Django` | PyPI | From 1.8a1 | 1.8b2 |

Products: Djangoproject Django.

## How do I fix CVE-2015-2241?

Upgrade django to a fixed version for your release line: 1.7.6 or 1.8b2.

## Is CVE-2015-2241 being exploited?

There is no known exploitation of CVE-2015-2241 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-2241 and fix it if it is affected.

What it is: CVE-2015-2241 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 12 Mar 2015. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-2241 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected all versions; fixed in 1.7.6, 1.8b2
- django (PyPI): affected all versions; fixed in 1.7.6
- django (PyPI): affected from 1.8a1; fixed in 1.8b2
- Django (PyPI): affected all versions; fixed in 1.7.6
- Django (PyPI): affected from 1.8a1; fixed in 1.8b2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-2241/ (Markdown: https://insights.sbomify.com/CVE-2015-2241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-2241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-2241
- OSV: https://osv.dev/vulnerability/CVE-2015-2241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-2241/
Summaries are generated and may contain mistakes; the official description above is the record.
