CVE-2015-2266 Moodle allows attackers to obtain sensitive personal-contact and unread-message-count information
Authenticated users can access arbitrary conversations and view sensitive contact information by bypassing capability checks in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-2266?
CVE-2015-2266 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
message/index.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/site:readallmessages capability before accessing arbitrary conversations, which allows remote authenticated users to obtain sensitive personal-contact and unread-message-count information via a modified URL.
Weakness: CWE-200
Which versions are affected by CVE-2015-2266?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.6.9 |
moodle/moodle Packagist | All versions | 2.6.9 |
moodle/moodle Packagist | From 2.7.0 | 2.7.6 |
moodle/moodle Packagist | From 2.7.0 | 2.7.6 |
moodle/moodle Packagist | From 2.8.0 | 2.8.4 |
moodle/moodle Packagist | From 2.8.0 | 2.8.4 |
Products include Moodle Moodle.
How do I fix CVE-2015-2266?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.9, 2.7.6 or 2.8.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2015-2266 being exploited?
There is no known exploitation of CVE-2015-2266 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-35pr-gqm6-r366.