CVE-2015-2267 Moodle allows attackers to extract archives to arbitrary directories

Medium 4.0 Published Updated

Authenticated users can bypass access restrictions to extract archives to arbitrary directories via a crafted dataroot value in Moodle.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-2267?

CVE-2015-2267 is a medium-severity path traversal vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

mdeploy.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to bypass intended access restrictions and extract archives to arbitrary directories via a crafted dataroot value.

Weakness: CWE-284

Which versions are affected by CVE-2015-2267?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.6.9
moodle/moodle PackagistAll versions2.6.9
moodle/moodle PackagistFrom 2.7.02.7.6
moodle/moodle PackagistFrom 2.7.02.7.6
moodle/moodle PackagistFrom 2.8.02.8.4
moodle/moodle PackagistFrom 2.8.02.8.4

Products include Moodle Moodle.

How do I fix CVE-2015-2267?

Upgrade moodle/moodle to a fixed version for your release line: 2.6.9, 2.7.6 or 2.8.4.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2015-2267 being exploited?

There is no known exploitation of CVE-2015-2267 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-cm4r-58pj-h2ph.

Is CVE-2015-2267 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free