CVE-2015-2268 Moodle allows attackers to cause a denial of service
Authenticated users can cause a denial of service in Moodle via a crafted string triggering excessive CPU consumption in URL filtering.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-2268?
CVE-2015-2268 is a medium-severity denial of service vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
filter/urltolink/filter.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to cause a denial of service (CPU consumption or partial outage) via a crafted string that is matched against an improper regular expression.
Weakness: CWE-399
Which versions are affected by CVE-2015-2268?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.6.9 |
moodle/moodle Packagist | All versions | 2.6.9 |
moodle/moodle Packagist | From 2.7.0 | 2.7.6 |
moodle/moodle Packagist | From 2.7.0 | 2.7.6 |
moodle/moodle Packagist | From 2.8.0 | 2.8.4 |
moodle/moodle Packagist | From 2.8.0 | 2.8.4 |
Products include Moodle Moodle.
How do I fix CVE-2015-2268?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.9, 2.7.6 or 2.8.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2015-2268 being exploited?
There is no known exploitation of CVE-2015-2268 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-36cm-vrqh-8p98.