CVE-2015-2269 Moodle XSS Vulnerability
Authenticated users can inject arbitrary scripts via image attributes in Moodle, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-2269?
CVE-2015-2269 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.
Weakness: CWE-79
Which versions are affected by CVE-2015-2269?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions to 2.5.9 | None |
moodle/moodle Packagist | All versions to 2.5.9 | None |
moodle/moodle Packagist | From 2.6.0 | 2.6.9 |
moodle/moodle Packagist | From 2.6.0 | 2.6.9 |
moodle/moodle Packagist | From 2.7.0 | 2.7.6 |
moodle/moodle Packagist | From 2.7.0 | 2.7.6 |
2 more packages
moodle/moodle Packagist | From 2.8.0 | 2.8.4 |
moodle/moodle Packagist | From 2.8.0 | 2.8.4 |
Products include Moodle Moodle.
How do I fix CVE-2015-2269?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.9, 2.7.6 or 2.8.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2015-2269 being exploited?
There is no known exploitation of CVE-2015-2269 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-cp39-43xr-2wrp.