CVE-2015-2270 Moodle allows attackers to obtain sensitive course information

Medium 4.3 Published Updated

Remote attackers can obtain sensitive course information due to incorrect state establishment during login validation in Moodle.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-2270?

CVE-2015-2270 is a medium-severity vulnerability in Moodle Moodle, published on 1 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

lib/moodlelib.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4, when the theme uses the blocks-regions feature, establishes the course state at an incorrect point in the login-validation process, which allows remote attackers to obtain sensitive course information via unspecified vectors.

Weakness: CWE-17

Which versions are affected by CVE-2015-2270?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.6.9
moodle/moodle PackagistAll versions2.6.9
moodle/moodle PackagistFrom 2.7.02.7.6
moodle/moodle PackagistFrom 2.7.02.7.6
moodle/moodle PackagistFrom 2.8.02.8.4
moodle/moodle PackagistFrom 2.8.02.8.4

Products include Moodle Moodle.

How do I fix CVE-2015-2270?

Upgrade moodle/moodle to a fixed version for your release line: 2.6.9, 2.7.6 or 2.8.4.

Is CVE-2015-2270 being exploited?

There is no known exploitation of CVE-2015-2270 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-fp4h-j22r-vwcv.

Is CVE-2015-2270 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free