# CVE-2015-2296: Python Requests Session Fixation

> Remote attackers can hijack user sessions via crafted redirect cookies in the requests library, potentially leading to account takeover.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-2296, GHSA-pg2w-x9wp-vw92, MGASA-2015-0120, PYSEC-2015-17, SUSE-SU-2015:2156-1, SUSE-SU-2016:0114-1, UBUNTU-CVE-2015-2296, USN-2531-1

## What is CVE-2015-2296?

CVE-2015-2296 is a medium-severity authentication bypass vulnerability in Canonical Ubuntu Linux, published on 18 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The resolve_redirects function in sessions.py in requests 2.1.0 through 2.5.3 allows remote attackers to conduct session fixation attacks via a cookie without a host value in a redirect.

## Which versions are affected by CVE-2015-2296?

3 open source packages ship an affected version, including requests. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `requests` | PyPI | From 2.1.0 | 2.6.0 |
| `requests` | PyPI | From 2.1.0 | 2.6.0 |
| `requests` | PyPI | From 2.1.0 | 2.6.0 |
| `python-requests` | SUSE:Cloud Compute Node for SUSE Linux Enterprise 12 5 | All versions | 2.8.1-6.9.1 |
| `python-requests` | SUSE:Enterprise Storage 1.0 | All versions | 2.8.1-6.9.1 |
| `python-requests` | SUSE:Enterprise Storage 2 | All versions | 2.8.1-6.9.1 |
| `python-requests` | SUSE:Linux Enterprise Desktop 12 SP1 | All versions | 2.8.1-6.9.1 |
| `python-requests` | SUSE:Linux Enterprise High Availability Extension 12 | All versions | 2.8.1-6.9.1 |
| `python-requests` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 2.8.1-6.9.1 |
| `python-requests` | SUSE:Linux Enterprise Server 12 | All versions | 2.8.1-6.9.1 |
| `python-requests` | SUSE:Linux Enterprise Server 12 SP1 | All versions | 2.8.1-6.9.1 |
| `python-requests` | SUSE:Linux Enterprise Server for SAP Applications 12 | All versions | 2.8.1-6.9.1 |
| `python-requests` | SUSE:Linux Enterprise Server for SAP Applications 12 SP1 | All versions | 2.8.1-6.9.1 |
| `python-requests` | SUSE:OpenStack Cloud 5 | All versions | 2.3.0-9.2 |

Products: Canonical Ubuntu Linux, Mageia Project Mageia, Python Requests.

## How do I fix CVE-2015-2296?

Upgrade requests to 2.6.0 or later.

## Is CVE-2015-2296 being exploited?

There is no known exploitation of CVE-2015-2296 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-2296 and fix it if it is affected.

What it is: CVE-2015-2296 is a medium-severity authentication bypass vulnerability in Canonical Ubuntu Linux, published on 18 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-2296 in the wild and no public exploit code.

Affected packages and fixed versions:
- requests (PyPI): affected from 2.1.0; fixed in 2.6.0
- requests (PyPI): affected from 2.1.0; fixed in 2.6.0
- requests (PyPI): affected from 2.1.0; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-2296/ (Markdown: https://insights.sbomify.com/CVE-2015-2296/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-2296
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-2296
- OSV: https://osv.dev/vulnerability/CVE-2015-2296

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-2296/
Summaries are generated and may contain mistakes; the official description above is the record.
