CVE-2015-2308 Symfony Vulnerable to PHP Eval Injection
Remote attackers can execute arbitrary PHP code via eval injection in Symfony HttpKernel's HttpCache class.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-2308?
CVE-2015-2308 is a medium-severity code injection vulnerability in Sensiolabs Symfony, published on 24 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Eval injection vulnerability in the HttpCache class in HttpKernel in Symfony 2.x before 2.3.27, 2.4.x and 2.5.x before 2.5.11, and 2.6.x before 2.6.6 allows remote attackers to execute arbitrary PHP code via a language="php" attribute of a SCRIPT element.
Weakness: CWE-94
Which versions are affected by CVE-2015-2308?
12 open source packages ship an affected version, including symfony/http-kernel and symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/http-kernel Packagist | From 2.0.0 | 2.3.27 |
symfony/http-kernel Packagist | From 2.0.0 | 2.3.27 |
symfony/http-kernel Packagist | From 2.4.0 | 2.5.11 |
symfony/http-kernel Packagist | From 2.4.0 | 2.5.11 |
symfony/http-kernel Packagist | From 2.6.0 | 2.6.6 |
symfony/http-kernel Packagist | From 2.6.0 | 2.6.6 |
6 more packages
symfony/symfony Packagist | From 2.0.0 | 2.3.27 |
symfony/symfony Packagist | From 2.0.0 | 2.3.27 |
symfony/symfony Packagist | From 2.4.0 | 2.5.11 |
symfony/symfony Packagist | From 2.4.0 | 2.5.11 |
symfony/symfony Packagist | From 2.6.0 | 2.6.6 |
symfony/symfony Packagist | From 2.6.0 | 2.6.6 |
Products include Sensiolabs Symfony.
How do I fix CVE-2015-2308?
Upgrade symfony/http-kernel to a fixed version for your release line: 2.3.27, 2.5.11 or 2.6.6.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2015-2308 being exploited?
There is no known exploitation of CVE-2015-2308 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as DEBIAN-CVE-2015-2308, GHSA-5c58-w9xc-qcj9.