CVE-2015-2316 Django Denial-of-service possibility with strip_tags
Remote attackers can cause a denial of service via infinite loop in Django's strip_tags function by sending long input strings.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-2316?
CVE-2015-2316 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 25 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The utils.html.strip_tags function in Django 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1, when using certain versions of Python, allows remote attackers to cause a denial of service (infinite loop) by increasing the length of the input string.
Weakness: CWE-399
Which versions are affected by CVE-2015-2316?
7 open source packages ship an affected version, including django and Django. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | From 1.6 | 1.6.11, 1.7.7, 1.8c1 |
django PyPI | From 1.6 | 1.6.11 |
django PyPI | From 1.7 | 1.7.7 |
django PyPI | From 1.8a1 | 1.8c1 |
Django PyPI | From 1.6 | 1.6.11 |
Django PyPI | From 1.7 | 1.7.7 |
1 more packages
Django PyPI | From 1.8a1 | 1.8c1 |
Products include Canonical Ubuntu Linux, Djangoproject Django, Fedoraproject Fedora, Opensuse Opensuse, Oracle Solaris.
How do I fix CVE-2015-2316?
Upgrade django to a fixed version for your release line: 1.6.11, 1.7.7 or 1.8c1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2015-2316 being exploited?
There is no known exploitation of CVE-2015-2316 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2015-2316, GHSA-j3j3-jrfh-cm2w, PYSEC-2015-18, UBUNTU-CVE-2015-2316.