# CVE-2015-2316: Django Denial-of-service possibility with strip_tags

> Remote attackers can cause a denial of service via infinite loop in Django's strip_tags function by sending long input strings.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-2316, GHSA-j3j3-jrfh-cm2w, PYSEC-2015-18, UBUNTU-CVE-2015-2316

## What is CVE-2015-2316?

CVE-2015-2316 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 25 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The utils.html.strip_tags function in Django 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1, when using certain versions of Python, allows remote attackers to cause a denial of service (infinite loop) by increasing the length of the input string.

Weakness: CWE-399

## Which versions are affected by CVE-2015-2316?

7 open source packages ship an affected version, including django and Django. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.6 | 1.6.11, 1.7.7, 1.8c1 |
| `django` | PyPI | From 1.6 | 1.6.11 |
| `django` | PyPI | From 1.7 | 1.7.7 |
| `django` | PyPI | From 1.8a1 | 1.8c1 |
| `Django` | PyPI | From 1.6 | 1.6.11 |
| `Django` | PyPI | From 1.7 | 1.7.7 |
| `Django` | PyPI | From 1.8a1 | 1.8c1 |

Products: Canonical Ubuntu Linux, Djangoproject Django, Fedoraproject Fedora, Opensuse Opensuse, Oracle Solaris.

## How do I fix CVE-2015-2316?

Upgrade django to a fixed version for your release line: 1.6.11, 1.7.7 or 1.8c1.

## Is CVE-2015-2316 being exploited?

There is no known exploitation of CVE-2015-2316 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-2316 and fix it if it is affected.

What it is: CVE-2015-2316 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 25 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-2316 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.6; fixed in 1.6.11, 1.7.7, 1.8c1
- django (PyPI): affected from 1.6; fixed in 1.6.11
- django (PyPI): affected from 1.7; fixed in 1.7.7
- django (PyPI): affected from 1.8a1; fixed in 1.8c1
- Django (PyPI): affected from 1.6; fixed in 1.6.11
- Django (PyPI): affected from 1.7; fixed in 1.7.7
- Django (PyPI): affected from 1.8a1; fixed in 1.8c1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-2316/ (Markdown: https://insights.sbomify.com/CVE-2015-2316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-2316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-2316
- OSV: https://osv.dev/vulnerability/CVE-2015-2316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-2316/
Summaries are generated and may contain mistakes; the official description above is the record.
