{"answers":{"affected":"3 open source packages ship an affected version, including restkit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-2674 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-2674 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-2674 is a medium-severity vulnerability in n/a, published on 9 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-2674 and fix it if it is affected.\n\nWhat it is: CVE-2015-2674 is a medium-severity vulnerability in n/a, published on 9 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-2674 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- restkit (PyPI): affected all versions up to 4.2.2; no fix listed\n- restkit (PyPI): affected all versions up to 4.2.2; no fix listed\n- restkit (PyPI): affected from 1.0.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-2674/ (Markdown: https://insights.sbomify.com/CVE-2015-2674/index.md)","id":"CVE-2015-2674","markdown":"https://insights.sbomify.com/CVE-2015-2674/index.md","name":"CVE-2015-2674","record":{"aliases":["GHSA-p9cv-hrxr-fxx8","PYSEC-2017-69","UBUNTU-CVE-2015-2674"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python REST client library","requires_auth":"none","summary":"Man-in-the-middle attackers can spoof TLS servers because the library uses default settings that disable certificate verification.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"restkit","vendor":"restkit"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Restkit allows man-in-the-middle attackers to spoof TLS servers by leveraging use of the ssl.wrap_socket function in Python with the default CERT_NONE value for the cert_reqs argument.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Restkit Does Not Validate TLS certificates","id":"CVE-2015-2674","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2015"},"n_packages":3,"n_references":3,"next":{"headline":"Null dereference in n/a","id":"CVE-2015-2675"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["4.2.2"],"package":"restkit","purl":null,"source":"GHSA-p9cv-hrxr-fxx8"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["4.2.2"],"package":"restkit","purl":"pkg:pypi/restkit","source":"GHSA-p9cv-hrxr-fxx8"},{"ecosystem":"PyPI","fixed":[],"introduced":["1.0.0"],"last_affected":[],"package":"restkit","purl":"pkg:pypi/restkit","source":"PYSEC-2017-69"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2015-2673"},"products":["n/a"],"published":"2017-08-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can spoof TLS servers because the library uses default settings that disable certificate verification.","url":"https://insights.sbomify.com/CVE-2015-2674/"}