# CVE-2015-2687: OpenStack Compute (Nova) Improper Access Control

> Local users can access unauthorized VM volumes when live migration fails in OpenStack Compute, requiring a patch to enforce proper permissions.

- **Severity:** Medium 4.7 (`CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-2687, GHSA-97fv-22hc-mrgj, PYSEC-2017-145

## What is CVE-2015-2687?

CVE-2015-2687 is a medium-severity missing authorization vulnerability in n/a, published on 9 Aug 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenStack Compute (nova) Icehouse, Juno and Havana when live migration fails allows local users to access VM volumes that they would normally not have permissions for.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2015-2687?

3 open source packages ship an affected version, including nova. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nova` | PyPI | All versions | 15.0.0.0b1 |
| `nova` | PyPI | All versions | 15.0.0.0b1 |
| `nova` | PyPI | All versions | 15.0.0.0b1 |

Products: Openstack Compute.

## How do I fix CVE-2015-2687?

Upgrade nova to 15.0.0.0b1 or later.

## Is CVE-2015-2687 being exploited?

There is no known exploitation of CVE-2015-2687 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-7130](https://insights.sbomify.com/CVE-2013-7130/): OpenStack Nova Live migration can leak root disk into ephemeral storage (high 7.1)
- [CVE-2014-0167](https://insights.sbomify.com/CVE-2014-0167/): OpenStack Compute (Nova) allows remote authenticated users to gain privileges via API requests (medium 6.0)
- [CVE-2013-4179](https://insights.sbomify.com/CVE-2013-4179/): OpenStack Compute (Nova) vulnerable to denial of service via XML Entity Expansion attack (medium 4.3)
- [CVE-2012-2654](https://insights.sbomify.com/CVE-2012-2654/): OpenStack Compute (Nova) Improper Input Validation (medium 4.3)
- [CVE-2013-4185](https://insights.sbomify.com/CVE-2013-4185/): OpenStack Nova Denial of Service in network source security groups (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-2687 and fix it if it is affected.

What it is: CVE-2015-2687 is a medium-severity missing authorization vulnerability in n/a, published on 9 Aug 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-2687 in the wild and no public exploit code.

Affected packages and fixed versions:
- nova (PyPI): affected all versions; fixed in 15.0.0.0b1
- nova (PyPI): affected all versions; fixed in 15.0.0.0b1
- nova (PyPI): affected all versions; fixed in 15.0.0.0b1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-2687/ (Markdown: https://insights.sbomify.com/CVE-2015-2687/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-2687
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-2687
- OSV: https://osv.dev/vulnerability/CVE-2015-2687

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-2687/
Summaries are generated and may contain mistakes; the official description above is the record.
