{"answers":{"affected":"2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-2794 exists.","fix":"Upgrade DotNetNuke.Core to 7.4.1 or later.","what":"CVE-2015-2794 is a critical authentication bypass vulnerability in Dnnsoftware Dotnetnuke, published on 6 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-2794 and fix it if it is affected.\n\nWhat it is: CVE-2015-2794 is a critical authentication bypass vulnerability in Dnnsoftware Dotnetnuke, published on 6 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-2794 exists.\n\nAffected packages and fixed versions:\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 7.4.1\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 7.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-2794/ (Markdown: https://insights.sbomify.com/CVE-2015-2794/index.md)","id":"CVE-2015-2794","markdown":"https://insights.sbomify.com/CVE-2015-2794/index.md","name":"CVE-2015-2794","record":{"aliases":["GHSA-x8f7-h444-97w4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"DotNetNuke CMS","requires_auth":"none","summary":"Remote attackers can reinstall the application and gain SuperUser access by directly requesting the installation wizard page.\n","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dotnetnuke","vendor":"dnnsoftware"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"The installation wizard in DotNetNuke (DNN) before 7.4.1 allows remote attackers to reinstall the application and gain SuperUser access via a direct request to Install/InstallWizard.aspx.","ecosystems":["NuGet"],"exploits":{"exploitdb":1,"first_seen":"2016-05-06","github_poc":2,"max_poc_stars":0,"metasploit":0,"nuclei":1,"refs":[{"date":"2016-05-06","kind":"exploitdb","ref":"39777","stars":null,"title":"DotNetNuke 07.04.00 - Administration Authentication Bypass"},{"date":"2016-05-07T12:21:13Z","kind":"github_poc","ref":"https://github.com/styx00/DNN_CVE-2015-2794","stars":0,"title":"NSE plugin for Nmap that scans a DotNetNuke (DNN) web application for an Administration Authentication Bypass vulnerability (CVE-2015-2794, EDB-ID: 39777)."},{"date":"2019-01-20T12:48:36Z","kind":"github_poc","ref":"https://github.com/wilsc0w/CVE-2015-2794-finder","stars":0,"title":"CVE-2015-2794 auto finder"},{"date":null,"kind":"nuclei","ref":"http/cves/2015/CVE-2015-2794.yaml","stars":null,"title":"DotNetNuke 07.04.00 - Administration Authentication Bypass"}],"tier":"weaponised"},"has_fix":true,"headline":"The installation wizard in DotNetNuke (DNN) allows privilege escalation","id":"CVE-2015-2794","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":"dnnsoftware:dotnetnuke","products":["dnnsoftware:dotnetnuke"],"type":"auth_bypass","year":"2015"},"n_packages":2,"n_references":5,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-2796"},"packages":[{"ecosystem":"NuGet","fixed":["7.4.1"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":null,"source":"GHSA-x8f7-h444-97w4"},{"ecosystem":"NuGet","fixed":["7.4.1"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":"pkg:nuget/DotNetNuke.Core","source":"GHSA-x8f7-h444-97w4"}],"prev":{"headline":"Cross-site scripting in ikiwiki","id":"CVE-2015-2793"},"products":["n/a"],"published":"2017-02-06","related":[{"cvss_score":8.8,"headline":"DotNetNuke (DNN) Remote Code Execution","id":"CVE-2017-9822","kev_date_added":"2021-11-03","published":"2017-07-20"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-15811","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-18325","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":10,"headline":"DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite","id":"CVE-2025-64095","kev_date_added":null,"published":"2025-10-28"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2006-3601","kev_date_added":null,"published":"2006-07-14"},{"cvss_score":9.1,"headline":"DotNetNuke.Core Vulnerable to Stored XSS via Module Title","id":"CVE-2026-24838","kev_date_added":null,"published":"2026-01-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can reinstall the application and gain SuperUser access by directly requesting the installation wizard page.\n","url":"https://insights.sbomify.com/CVE-2015-2794/"}