# CVE-2015-2794: The installation wizard in DotNetNuke (DNN) allows privilege escalation

> Remote attackers can reinstall the application and gain SuperUser access by directly requesting the installation wizard page.


- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-x8f7-h444-97w4

## What is CVE-2015-2794?

CVE-2015-2794 is a critical authentication bypass vulnerability in Dnnsoftware Dotnetnuke, published on 6 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The installation wizard in DotNetNuke (DNN) before 7.4.1 allows remote attackers to reinstall the application and gain SuperUser access via a direct request to Install/InstallWizard.aspx.

Weakness: CWE-264

## Which versions are affected by CVE-2015-2794?

2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | All versions | 7.4.1 |
| `DotNetNuke.Core` | NuGet | All versions | 7.4.1 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2015-2794?

Upgrade DotNetNuke.Core to 7.4.1 or later.

## Is CVE-2015-2794 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-2794 exists.

Public exploit code:

- DotNetNuke 07.04.00 - Administration Authentication Bypass (exploitdb)
- NSE plugin for Nmap that scans a DotNetNuke (DNN) web application for an Administration Authentication Bypass vulnerability (CVE-2015-2794, EDB-ID: 39777). (github_poc): https://github.com/styx00/DNN_CVE-2015-2794
- CVE-2015-2794 auto finder (github_poc): https://github.com/wilsc0w/CVE-2015-2794-finder
- DotNetNuke 07.04.00 - Administration Authentication Bypass (nuclei): http/cves/2015/CVE-2015-2794.yaml

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-2794 and fix it if it is affected.

What it is: CVE-2015-2794 is a critical authentication bypass vulnerability in Dnnsoftware Dotnetnuke, published on 6 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-2794 exists.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected all versions; fixed in 7.4.1
- DotNetNuke.Core (NuGet): affected all versions; fixed in 7.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-2794/ (Markdown: https://insights.sbomify.com/CVE-2015-2794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-2794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-2794
- OSV: https://osv.dev/vulnerability/CVE-2015-2794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-2794/
Summaries are generated and may contain mistakes; the official description above is the record.
