CVE-2015-2912 OrientDB-Server vulnerable to Cross-Site Request Forgery

High 8.8 Published Updated

Remote attackers can exploit a JSONP endpoint flaw in OrientDB Server to perform CSRF attacks and access sensitive information.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-2912?

CVE-2015-2912 is a high-severity vulnerability in n/a, published on 31 Dec 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The JSONP endpoint in the Studio component in OrientDB Server Community Edition before 2.0.15 and 2.1.x before 2.1.1 does not properly restrict callback values, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks, and obtain sensitive information, via a crafted HTTP request.

Weakness: CWE-352

Which versions are affected by CVE-2015-2912?

4 open source packages ship an affected version, including com.orientechnologies:orientdb-studio. It affects 1 product.

PackageAffectedFixed in
com.orientechnologies:orientdb-studio MavenAll versions2.0.15
com.orientechnologies:orientdb-studio MavenAll versions2.0.15
com.orientechnologies:orientdb-studio MavenFrom 2.1.02.1.1
com.orientechnologies:orientdb-studio MavenFrom 2.1.02.1.1

Products include Orientdb Orientdb.

How do I fix CVE-2015-2912?

Upgrade com.orientechnologies:orientdb-studio to a fixed version for your release line: 2.0.15 or 2.1.1.

Is CVE-2015-2912 being exploited?

There is no known exploitation of CVE-2015-2912 in the wild and no public exploit code.

Sources

Also known as GHSA-p8ww-vv84-c2rm.

Is CVE-2015-2912 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free