# CVE-2015-2912: OrientDB-Server vulnerable to Cross-Site Request Forgery

> Remote attackers can exploit a JSONP endpoint flaw in OrientDB Server to perform CSRF attacks and access sensitive information.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Dec 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p8ww-vv84-c2rm

## What is CVE-2015-2912?

CVE-2015-2912 is a high-severity vulnerability in n/a, published on 31 Dec 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The JSONP endpoint in the Studio component in OrientDB Server Community Edition before 2.0.15 and 2.1.x before 2.1.1 does not properly restrict callback values, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks, and obtain sensitive information, via a crafted HTTP request.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2015-2912?

4 open source packages ship an affected version, including com.orientechnologies:orientdb-studio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.orientechnologies:orientdb-studio` | Maven | All versions | 2.0.15 |
| `com.orientechnologies:orientdb-studio` | Maven | All versions | 2.0.15 |
| `com.orientechnologies:orientdb-studio` | Maven | From 2.1.0 | 2.1.1 |
| `com.orientechnologies:orientdb-studio` | Maven | From 2.1.0 | 2.1.1 |

Products: Orientdb Orientdb.

## How do I fix CVE-2015-2912?

Upgrade com.orientechnologies:orientdb-studio to a fixed version for your release line: 2.0.15 or 2.1.1.

## Is CVE-2015-2912 being exploited?

There is no known exploitation of CVE-2015-2912 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-11467](https://insights.sbomify.com/CVE-2017-11467/): OrientDB vulnerable to Improper Privilage Management leading to arbitrary command injection (critical 9.8)
- [CVE-2015-2918](https://insights.sbomify.com/CVE-2015-2918/): OrientDB Studio web management interface is vulnerable to clickjacking attacks (medium 6.1)
- [CVE-2015-2913](https://insights.sbomify.com/CVE-2015-2913/): OrientDB Server Community Edition uses insufficiently random values to generate session IDs (medium 5.9)
- [CVE-2019-25447](https://insights.sbomify.com/CVE-2019-25447/): OrientDB 3.0.17 Cross-Site Request Forgery (medium 5.3)
- [CVE-2019-25448](https://insights.sbomify.com/CVE-2019-25448/): OrientDB 3.0.17 Stored Cross-Site Scripting via User Creation (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-2912 and fix it if it is affected.

What it is: CVE-2015-2912 is a high-severity vulnerability in n/a, published on 31 Dec 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-2912 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.orientechnologies:orientdb-studio (Maven): affected all versions; fixed in 2.0.15
- com.orientechnologies:orientdb-studio (Maven): affected all versions; fixed in 2.0.15
- com.orientechnologies:orientdb-studio (Maven): affected from 2.1.0; fixed in 2.1.1
- com.orientechnologies:orientdb-studio (Maven): affected from 2.1.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-2912/ (Markdown: https://insights.sbomify.com/CVE-2015-2912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-2912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-2912
- OSV: https://osv.dev/vulnerability/CVE-2015-2912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-2912/
Summaries are generated and may contain mistakes; the official description above is the record.
