CVE-2015-2913 OrientDB Server Community Edition uses insufficiently random values to generate session IDs

Medium 5.9 Published Updated

Attackers can predict session IDs due to weak random number generation, potentially leading to account takeover in OrientDB Server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-2913?

CVE-2015-2913 is a medium-severity vulnerability in n/a, published on 31 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

server/network/protocol/http/OHttpSessionManager.java in the Studio component in OrientDB Server Community Edition before 2.0.15 and 2.1.x before 2.1.1 improperly relies on the java.util.Random class for generation of random Session ID values, which makes it easier for remote attackers to predict a value by determining the internal state of the PRNG in this class.

Weakness: CWE-200

Which versions are affected by CVE-2015-2913?

4 open source packages ship an affected version, including com.orientechnologies:orientdb-server. It affects 1 product.

PackageAffectedFixed in
com.orientechnologies:orientdb-server MavenAll versions2.0.15
com.orientechnologies:orientdb-server MavenAll versions2.0.15
com.orientechnologies:orientdb-server MavenFrom 2.1.02.1.1
com.orientechnologies:orientdb-server MavenFrom 2.1.02.1.1

Products include Orientdb Orientdb.

How do I fix CVE-2015-2913?

Upgrade com.orientechnologies:orientdb-server to a fixed version for your release line: 2.0.15 or 2.1.1.

Is CVE-2015-2913 being exploited?

There is no known exploitation of CVE-2015-2913 in the wild and no public exploit code.

Sources

Also known as GHSA-v6wr-fch2-vm5w.

Is CVE-2015-2913 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free