{"answers":{"affected":"2 open source packages ship an affected version, including paperclip. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-2963 in the wild and no public exploit code.","fix":"Upgrade paperclip to 4.2.2 or later.","what":"CVE-2015-2963 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Jul 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-2963 and fix it if it is affected.\n\nWhat it is: CVE-2015-2963 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Jul 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-2963 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paperclip (RubyGems): affected all versions; fixed in 4.2.2\n- paperclip (RubyGems): affected all versions; fixed in 4.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-2963/ (Markdown: https://insights.sbomify.com/CVE-2015-2963/index.md)","id":"CVE-2015-2963","markdown":"https://insights.sbomify.com/CVE-2015-2963/index.md","name":"CVE-2015-2963","record":{"aliases":["GHSA-6jvm-3j5h-79f6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby file upload library","requires_auth":"low_privilege","summary":"Remote attackers can upload HTML files with spoofed content types to execute cross-site scripting attacks in applications using the Paperclip gem.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"paperclip","vendor":"thoughtbot"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The thoughtbot paperclip gem before 4.2.2 for Ruby does not consider the content-type value during media-type validation, which allows remote attackers to upload HTML documents and conduct cross-site scripting (XSS) attacks via a spoofed value, as demonstrated by image/jpeg.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"paperclip Cross-site Scripting vulnerability","id":"CVE-2015-2963","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2015"},"n_packages":2,"n_references":6,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2015-2964"},"packages":[{"ecosystem":"RubyGems","fixed":["4.2.2"],"introduced":["0"],"last_affected":[],"package":"paperclip","purl":null,"source":"GHSA-6jvm-3j5h-79f6"},{"ecosystem":"RubyGems","fixed":["4.2.2"],"introduced":["0"],"last_affected":[],"package":"paperclip","purl":"pkg:gem/paperclip","source":"GHSA-6jvm-3j5h-79f6"}],"prev":{"headline":"File upload in n/a","id":"CVE-2015-2962"},"products":["n/a"],"published":"2015-07-10","related":[{"cvss_score":9.8,"headline":"paperclip Server-Side Request Forgery vulnerability","id":"CVE-2017-0889","kev_date_added":null,"published":"2017-11-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can upload HTML files with spoofed content types to execute cross-site scripting attacks in applications using the Paperclip gem.","url":"https://insights.sbomify.com/CVE-2015-2963/"}