# CVE-2015-2963: paperclip Cross-site Scripting vulnerability

> Remote attackers can upload HTML files with spoofed content types to execute cross-site scripting attacks in applications using the Paperclip gem.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jul 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-6jvm-3j5h-79f6

## What is CVE-2015-2963?

CVE-2015-2963 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Jul 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The thoughtbot paperclip gem before 4.2.2 for Ruby does not consider the content-type value during media-type validation, which allows remote attackers to upload HTML documents and conduct cross-site scripting (XSS) attacks via a spoofed value, as demonstrated by image/jpeg.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-2963?

2 open source packages ship an affected version, including paperclip. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paperclip` | RubyGems | All versions | 4.2.2 |
| `paperclip` | RubyGems | All versions | 4.2.2 |

Products: Thoughtbot Paperclip.

## How do I fix CVE-2015-2963?

Upgrade paperclip to 4.2.2 or later.

## Is CVE-2015-2963 being exploited?

There is no known exploitation of CVE-2015-2963 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-0889](https://insights.sbomify.com/CVE-2017-0889/): paperclip Server-Side Request Forgery vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-2963 and fix it if it is affected.

What it is: CVE-2015-2963 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Jul 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-2963 in the wild and no public exploit code.

Affected packages and fixed versions:
- paperclip (RubyGems): affected all versions; fixed in 4.2.2
- paperclip (RubyGems): affected all versions; fixed in 4.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-2963/ (Markdown: https://insights.sbomify.com/CVE-2015-2963/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-2963
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-2963
- OSV: https://osv.dev/vulnerability/CVE-2015-2963

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-2963/
Summaries are generated and may contain mistakes; the official description above is the record.
