# CVE-2015-2992: Cross-site Scripting in Apache Struts

> Attackers can inject malicious scripts into web pages viewed by other users, potentially stealing session cookies or sensitive data.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Feb 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-265r-pp83-gww7

## What is CVE-2015-2992?

CVE-2015-2992 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 27 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache Struts before 2.3.20 has a cross-site scripting (XSS) vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-2992?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.3.20 |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.3.20 |

Products: Apache Struts.

## How do I fix CVE-2015-2992?

Upgrade org.apache.struts:struts2-core to 2.3.20 or later.

## Is CVE-2015-2992 being exploited?

There is no known exploitation of CVE-2015-2992 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-2992 and fix it if it is affected.

What it is: CVE-2015-2992 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 27 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-2992 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.3.20
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.3.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-2992/ (Markdown: https://insights.sbomify.com/CVE-2015-2992/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-2992
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-2992
- OSV: https://osv.dev/vulnerability/CVE-2015-2992

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-2992/
Summaries are generated and may contain mistakes; the official description above is the record.
