{"answers":{"affected":"3 open source packages ship an affected version, including ceph-deploy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-3010 in the wild and no public exploit code.","fix":"Upgrade ceph-deploy to 1.5.23 or later.","what":"CVE-2015-3010 is a low-severity vulnerability in n/a, published on 16 Jun 2015. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-3010 and fix it if it is affected.\n\nWhat it is: CVE-2015-3010 is a low-severity vulnerability in n/a, published on 16 Jun 2015. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-3010 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ceph-deploy (PyPI): affected all versions; fixed in 1.5.23\n- ceph-deploy (PyPI): affected all versions; fixed in 1.5.23\n- ceph-deploy (PyPI): affected all versions; fixed in 1.5.23\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3010/ (Markdown: https://insights.sbomify.com/CVE-2015-3010/index.md)","id":"CVE-2015-3010","markdown":"https://insights.sbomify.com/CVE-2015-3010/index.md","name":"CVE-2015-3010","record":{"aliases":["GHSA-9w4f-3v37-6f75","PYSEC-2015-2"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ceph deployment tool","requires_auth":"low_privilege","summary":"Local attackers can read sensitive Ceph admin keyring files due to weak file permissions in ceph-deploy.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ceph-deploy","vendor":"ceph"}],"cvss":{"score":2.1,"severity":"low","source":"nvd","vector":"AV:L/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"ceph-deploy before 1.5.23 uses weak permissions (644) for ceph/ceph.client.admin.keyring, which allows local users to obtain sensitive information by reading the file.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ceph-deploy allows local users to obtain sensitive information by reading the file","id":"CVE-2015-3010","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2015"},"n_packages":3,"n_references":9,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-3011"},"packages":[{"ecosystem":"PyPI","fixed":["1.5.23"],"introduced":["0"],"last_affected":[],"package":"ceph-deploy","purl":null,"source":"GHSA-9w4f-3v37-6f75"},{"ecosystem":"PyPI","fixed":["1.5.23"],"introduced":["0"],"last_affected":[],"package":"ceph-deploy","purl":"pkg:pypi/ceph-deploy","source":"GHSA-9w4f-3v37-6f75"},{"ecosystem":"PyPI","fixed":["1.5.23"],"introduced":["0"],"last_affected":[],"package":"ceph-deploy","purl":"pkg:pypi/ceph-deploy","source":"PYSEC-2015-2"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2015-3008"},"products":["n/a"],"published":"2015-06-16","related":[{"cvss_score":2.1,"headline":"ceph-deploy uses world-readable permissions on client.admin key","id":"CVE-2015-4053","kev_date_added":null,"published":"2015-06-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can read sensitive Ceph admin keyring files due to weak file permissions in ceph-deploy.","url":"https://insights.sbomify.com/CVE-2015-3010/"}