{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2015-3146 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-3146 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-3146 and fix it if it is affected.\n\nWhat it is: CVE-2015-3146 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-3146 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-3146/ (Markdown: https://insights.sbomify.com/CVE-2015-3146/index.md)","id":"CVE-2015-3146","markdown":"https://insights.sbomify.com/CVE-2015-3146/index.md","name":"CVE-2015-3146","record":{"aliases":["DEBIAN-CVE-2015-3146","GHSA-46jx-xcg7-prj7","MGASA-2015-0209","SUSE-SU-2015:1707-1","SUSE-SU-2015:1707-2","UBUNTU-CVE-2015-3146"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"libssh library","requires_auth":"none","summary":"Remote attackers can cause a denial of service via crafted SSH packets due to improper state validation in libssh.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"libssh","vendor":"libssh"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[],"description":"The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh before 0.6.5 do not properly validate state, which allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted SSH packet.","ecosystems":["SUSE:Linux Enterprise Desktop 12","SUSE:Linux Enterprise Software Development Kit 12","SUSE:Linux Enterprise Workstation Extension 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Null dereference in n/a","id":"CVE-2015-3146","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","fedoraproject:fedora"],"type":"null_dereference","year":"2015"},"n_packages":3,"n_references":7,"next":{"headline":"Path traversal in ABRT","id":"CVE-2015-3147"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12","fixed":["0.6.3-8.1"],"introduced":["0"],"last_affected":[],"package":"libssh","purl":"pkg:rpm/suse/libssh\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012","source":"SUSE-SU-2015:1707-2"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12","fixed":["0.6.3-8.1"],"introduced":["0"],"last_affected":[],"package":"libssh","purl":"pkg:rpm/suse/libssh\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012","source":"SUSE-SU-2015:1707-2"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12","fixed":["0.6.3-8.1"],"introduced":["0"],"last_affected":[],"package":"libssh","purl":"pkg:rpm/suse/libssh\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012","source":"SUSE-SU-2015:1707-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2015-3145"},"products":["n/a"],"published":"2016-04-13","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via crafted SSH packets due to improper state validation in libssh.","url":"https://insights.sbomify.com/CVE-2015-3146/"}