CVE-2015-3154 Zenario CMS vulnerable to CRLF injection
Remote attackers can inject arbitrary HTTP headers and conduct response splitting via CRLF sequences in email headers using Zend Framework.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-3154?
CVE-2015-3154 is a medium-severity vulnerability in Zend Framework, published on 27 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
CRLF injection vulnerability in Zend\Mail (Zend_Mail) in Zend Framework before 1.12.12, 2.x before 2.3.8, and 2.4.x before 2.4.1 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via CRLF sequences in the header of an email.
Weakness: CWE-74
Which versions are affected by CVE-2015-3154?
12 open source packages ship an affected version, including zendframework/zend-http, zendframework/zendframework and zendframework/zendframework1. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
zendframework/zend-http Packagist | All versions | 1.12.12 |
zendframework/zend-http Packagist | All versions | 1.12.12 |
zendframework/zend-http Packagist | From 2.0.0beta4 | 2.3.8 |
zendframework/zend-http Packagist | From 2.0.0beta4 | 2.3.8 |
zendframework/zend-http Packagist | From 2.4.0rc1 | 2.4.1 |
zendframework/zend-http Packagist | From 2.4.0rc1 | 2.4.1 |
6 more packages
zendframework/zendframework Packagist | From 2.0.0beta4 | 2.3.8 |
zendframework/zendframework Packagist | From 2.0.0beta4 | 2.3.8 |
zendframework/zendframework Packagist | From 2.4.0rc1 | 2.4.1 |
zendframework/zendframework Packagist | From 2.4.0rc1 | 2.4.1 |
zendframework/zendframework1 Packagist | All versions | 1.12.12 |
zendframework/zendframework1 Packagist | All versions | 1.12.12 |
Products include Zend Zend Framework.
How do I fix CVE-2015-3154?
Upgrade zendframework/zend-http to a fixed version for your release line: 1.12.12, 2.3.8 or 2.4.1.
Is CVE-2015-3154 being exploited?
There is no known exploitation of CVE-2015-3154 in the wild and no public exploit code.
Other vulnerabilities in Zend Framework
Sources
Also known as CLSA-2026-1787214807, GHSA-5957-5crx-79jx, MGASA-2015-0241, UBUNTU-CVE-2015-3154.